Applicable to:
- Plesk for Linux
Symptoms
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A domain is behind Cloudflare proxy.
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When setting up an email account of this domain in a mail client (Outlook, Thunderbird, Mail for iOS, etc.), the operation fails due to a failed connection to the mail server.
Examples of error messages:
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Outlook:
PLESK_INFO: Log onto incoming mail server (IMAP): The connection to the server failed.
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Thunderbird:
PLESK_INFO: Unable to log in at server. Probably wrong configuration, username or password.
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Mail for iOS:
PLESK_INFO: The IMAP server "example.com" is not responding. Check your network connection and that you entered the correct information in the "Incoming Mail Server" field.
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PHP script:
PLESK_INFO: Connection could not be established with host example.com
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Cause
Cloudflare proxies only HTTP/HTTPS traffic and blocks other traffic including mail. A mail client tries to fetch the real IP address using a domain name to set up a connection, but fails because the request ends up on the Cloudflare side.
Resolution
For manual configuration
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Use mail.<domain_name>:
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Disable proxy traffic for mail.example.com in Cloudflare dashboard (if it is enabled).
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Set up an email account in a mail client using mail.example.com for incoming/outgoing mail server.
Note: Issue a wildcard SSL certificate for the domain example.com to add an email account using a secure connection.
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Configure an email account using the server hostname (if it is not behind Cloudflare) for incoming/outgoing mail server.
Note: Secure the mail server hostname with an SSL certificate to add an email account using a secure connection.
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Configure mail client using Plesk mail server IP address.
Note: In this scenario, the customer will receive an SSL warning when trying to set up an email account.
For autodiscovery
Note: For this solution to work, disable proxy traffic for mail.example.com in Cloudflare dashboard (if it is enabled).
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Install the Panel.ini Editor from the Extensions menu in Plesk.
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Open Panel.ini Editor at Extensions > My Extensions.
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In Panel.ini Editor, switch to the Editor tab and add the following configuration at the end of the file:
CONFIG_TEXT: [mail]
clientConfig.incomingServer="mail.<domain>"
clientConfig.outgoingServer="mail.<domain>" -
Apply the changes.
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Connect to the server via SSH.
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Open the
panel.ini
file in a text editor. In this example, we are using the vi editor:# vi /usr/local/psa/admin/conf/panel.ini
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Add the following lines:
CONFIG_TEXT: [mail]
clientConfig.incomingServer="mail.<domain>"
clientConfig.outgoingServer="mail.<domain>" -
Save the changes and close the file.
Comments
1 comment
I am the owner of domain zcf.sg with the hosting plan Linux Advanced (valid until 17.06.2034). From beginning of August 2024, all our emails installed on your server Linux New Plesk 02, Hostname: pl02.marcaria.net, IP address: 209.217.93.235 - are not working, even was working before. When we tried to reach-install on the IPhone - we are getting mistake: „The IMAP server: pl02.marcaria.net is not responding.“ Please check, how to solve this problem and establish stable connection with your Server. On PC or laptop - installation is also not possible, because of no response from pl02.marcaria.net.
Best regards, Nikolay
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