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Incorrect SSL certificate is detected for the domain hosted on a Plesk server with LiteSpeed

Plesk for Linux kb: technical ext: sslit

Applicable to:

  • Plesk for Linux 

Symptoms

    • The domain example.com provides a security warning in a browser:

      CONFIG_TEXT: SEC_ERROR_EXPIRED_CERTIFICATE

    • A new certificate was issued for the domain in Domains > example.com > SSL/TLS Certificates, however, the issue still persists.

    • This new certificate is assigned to the domain in Domains > example.com > Hosting & DNS tab > Hosting Settings in the Certificate drop-down list.

    • OpenSSL command and free online checkers provide information about the old certificate.

    • LiteSpeed is enabled on a Plesk server.

  • The correct certificate exists in the Apache configuration file of the domain

    # grep SSL /var/www/vhosts/system/example.com/conf/httpd.conf
    SSLEngine on
    SSLVerifyClient none
    SSLCertificateFile /usr/local/psa/var/certificates/scfBcG5GN
    SSLCACertificateFile /usr/local/psa/var/certificates/scfdPJUPx
    SSLRequireSSL

Cause

Hung LiteSpeed process prevents displaying of the new certificate:

# ps aux | grep lshttpd
root 2293 0.0 0.0 13444 1048 pts/0 S+ 00:51 0:00 grep lshttpd
root 12899 0.0 0.4 125304 71308 ? S May20 7:17 litespeed (lshttpd - main)
www-data 12904 0.6 0.8 1312392 138320 ? Sl May20 70:01 litespeed (lshttpd - #01)
www-data 12910 0.0 0.4 1324238 140321 ? Sl 00:12 0:00 litespeed (lshttpd - #02)

Resolution

  1. Log into Plesk.

  2. Navigate to Extensions > My Extensions > LiteSpeed Extension > Open.

  3. Restart LiteSpeed by clicking on the Restart LiteSpeed button.

In case the issue still persists after that, contact LiteSpeed Support.

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