Articles in this section

Unable to set up a mail autodiscover profile on iOS for a mailbox in Plesk: Invalid profile

kb: bug Plesk for Windows kb: fixed Plesk for Linux

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • In Domains > example.com > Mail Accounts > "info" button near mailbox > iOS Mail on iPhone or iPad tab while opening generated link (e.g.: https://example.com/email.mobileconfig?emailaddress=user@example.com) on an iOS device there is an error:

    CONFIG_TEXT: <Invalid Profile>
    Safari could not install a profile due to an unknown error

  • The following error appears on an attempt to `curl` the configured mailbox above:

    CONFIG_TEXT: {"type":"Zend_Exception","message":"No entry is registered for key 'container'","file":"Registry.php","line":147,"stackTrace":null,"codeFragment":null}

  • In the C:\Program Files (x86)\Plesk\admin\logs\php_error.log file there is the following error:

    CONFIG_TEXT: ERR [panel] No entry is registered for key 'container':
    0: C:\Program Files (x86)\Plesk\admin\plib\vendor\plesk\zf1\library\Zend\Registry.php:147
    Zend_Registry::get(string 'container')

Cause

Product issue:

  • #PPPM-13390 "Trying to set up mail autodiscover in the iOS Mail app on iPhone or iPad via the Plesk-generated link or QR code no longer fails with the “Invalid Profile” error."
    Fixed in:

Resolution

Please consider updating your server:

Workaround

If an update is not possible for some reason you may try the following:

workaround

Configure the mailbox manually as per the article How to configure mail client for the mailbox created in Plesk?

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.