Articles in this section

Mailboxes of a Subscription with suspended Customer, Subscription or Domain cannot be migrated by the Plesk Migrator

kb: bug Plesk for Windows Plesk for Linux ext: migrator

Applicable to:

  • Plesk for Linux

Symptoms

  • Mailboxes of a subscription with suspended owner, subscription or domain are not migrated by Plesk Migrator, while displaying an error message that is similar to the following:

    PLESK_ERROR: Unable to create mail account 'jdoe@example.com' in subscription 'example.com': Command execution failed on the local server with non-zero exit code.
    command: /usr/local/psa/bin/mail --create jdoe@example.com -mailbox true -passwd '' -cp-access true -ignore-nonexistent-options
    exit code: 1
    stdout:
    stderr: There is no DSMail service for domain with id = 2

Cause

This same issue was previously tied to a Plesk Migrator bug with ID #PMT-5002, which has already been reported as fixed in Plesk Migrator version 2.25.2.

Obsolete (or corrupted) leftover data tied to the migration of this Subscription's mailboxes remains in the Plesk Migrator and is preventing the process of migration for this Subscription to be completed correctly.

Resolution

You can resolve the issue by following these steps:

  1. Log into Plesk on the destination server
  2. Navigate to Tools & Settings > Migration & Transfer Manager and press on the active migration.
  3. Re-sync the affected subscriptions, while including their business objects and external IDs:

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.