Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Unable to update or install Plesk, the process fails an error message that is similar to the following:
CONFIG_TEXT: Syntax error in file C:\ParallelsInstaller\parallels\pool\release\PLESK-WIN_18.0.59_14022\release.inf3:
the root element is incorrectly named.CONFIG_TEXT: ERROR: Syntax error in file /root/parallels/pool/PSA_18.0.68_16616/release.inf3:
the root element is incorrectly named.
Not all packages were installed.
Visit https://support.plesk.com/ to search for a solution.
[Errno -2] Name or service not knownCONFIG_TEXT: ERROR: The root element is named incorrectly in the file /root/parallels/PHP83_17/php83-ubt22.04-x86_64.inf3
-
The
C:\ParallelsInstaller\parallels\pool\release\PLESK-WIN_18.0.59_14022\release.inf3(on Plesk for Windows) or/root/parallels/pool/PSA_18.0.68_16616/release.inf3(on Plesk for Linux) contains unexpected content such as the following, which confirms that it is corrupted:CONFIG_TEXT: <meta name="viewport" content="width=device-width,initial-scale=1.0,maximum-scale=1.0"/><style>body{margin:0px;padding:0px;}iframe{width:100%;height:100%}</style><iframe src="http://SOME_IP/webadmin/deny/dot.html" width="100%" height="100%" frameborder=0></iframe>
- Removing or replacing the
release.inf3file mentioned in the error does not fix the issue, since a corrupted version of the file is downloaded once again
Cause
Network restrictions or rules configured on the server or a network device on a level above the server are affecting the connection some of the Plesk update servers, due to which the information (or more specifically the release.inf3 files) that need to be downloaded are corrupted during the download process.
Resolution
Reach out to the administrators of your server network to ensure that there are no restrictions, rules or filters on all of the upper level network devices that may restrict downloading files from all of the Plesk update servers IP addresses.
If that doesn't help, as a workaround, you may set a specific IP address that does not create such issues when fetching the Plesk updates by following these steps:
1. Log in to the server via RDP
2. Open the C:\Windows\System32\Drivers\etc\hosts file with any text editor
3. Assign Plesk Updates servers to the IP of another country by adding a line such as the following into the hosts file:
CONFIG_TEXT: 207.211.211.26 autoinstall-win.plesk.com
1. Log in to the server via SSH
2. Open the /etc/hosts file with any command-line text editor
3. Make Plesk Updates be fetched from Plesk update servers from another country by adding a line such as the following into the hosts file:
CONFIG_TEXT: 207.211.211.26 autoinstall.plesk.com
Note: If one of the IPs from the list does not resolve the issue, try another one from the following list until you find one that works as expected:
143.244.51.245
89.187.187.12
143.244.51.59
138.199.57.100
109.61.91.197
37.19.194.81
212.102.56.178
169.150.255.180
207.211.211.26
79.127.206.207
Comments
Please sign in to leave a comment.