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Plesk for Windows installation fails: Failed to connect to autoinstall-win.plesk.com port 80

Plesk for Windows kb: technical

Symptoms

  • The Plesk installation on a Windows Server is failing with the following error:

PLESK_ERROR: Failed to read product information from the file : Can't process products.inf3: Failed to download the file
http://autoinstall-win.plesk.com/products.inf3(138.199.14.22):
Failed to connect to autoinstall-win.plesk.com port 80 after 43062 ms: Couldn't connect to server Can't process versions.inf3: Failed to download the file http://autoinstall-win.plesk.com/versions.inf3(138.199.14.21):
Failed to connect to autoinstall-win.plesk.com port 80 after 43062 ms: Couldn't connect to server

  • The ping requests to autoinstall-win.plesk.com are failing:

C:\> ping autoinstall-win.plesk.com 
Pinging 1131995712.rsc.cdn77.org [138.199.14.55] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 138.199.14.55:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

Cause

Connectivity issue from the server to one of the CDN IP addresses used by autoinstall-win.plesk.com.

Resolution

1. Access the server over RDP.

2. Open the C:\Windows\System32\Drivers\etc\hosts file with any text editor.

3. Add an entry in the server's hosts file to resolve autoinstall-win.plesk.com to one of the other CDN IP addresses:

CONFIG_TEXT: 89.187.177.17 autoinstall-win.plesk.com

Note: You can find all IP addresses that autoinstall-win.plesk.com resolves to by using a command-line tool such as dig or a web tool such as https://dnschecker.org.

5. Save the changes and close the file.

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