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Unable to access subscription: There is no IP address in the pool

Plesk for Windows Plesk for Linux kb: technical ABT: Group B

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Subscriptions > example.com is not accessible. The following error is shown instead:

    PLESK_ERROR: Internal error:
    There is no IP address 203.0.113.2 in the pool.
    Message There is no IP address 203.0.113.2 in the pool.
    File IPPoolManager.php
    Line 283
    Type PleskIPPoolException

  • IP address exist on the server - it is shown in the output of the command below:

    On Linux:

    # ip a | grep 203.0.113.2
    inet 203.0.113.2/25 brd 192.64.74.255 scope global eth0

    On Windows:

    C:\> ipconfig | findstr "203.0.113.2"
    IPv4 Address. . . . . . . . . . . : 203.0.113.2

Cause

The root cause is under investigation.

Resolution

  1. Connect to the server via SSH / RDP and open cmd.exe as Administrator.

  2. Update the IP address and set the same one for the subscription:

    # plesk bin subscription -u example.com -ip 203.0.113.2

    Note: This new IP address will be assigned to all domains in this subscription.

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