Articles in this section

Adding OVHcloud OpenStack-based S3-compatible storage as backup storage in Plesk fails: Unable to check bucket and directory existence

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • Adding OVHcloud OpenStack-based S3-compatible storage as a custom S3 storage in Plesk in Tools & Settings > Backup Manager > Remote Storage Settings > Amazon S3 Backup fails:

    PLESK_ERROR: Unable to check bucket and directory existence. Make sure you are using correct IAM policy (400 Bad Request (Request-ID: tx2ef843a36acf491fb4b79-005df2411f)).

  • The error message stays the same despite what is set in the field Path - the bucket root or a directory inside the bucket.

  • Key and secret are created correctly according to the corresponding OVH article.

  • Accessing the bucket and working with it using AWS CLI works correctly.

Cause

The region for a custom S3-compatible endpoint is not specified in the file /usr/local/psa/admin/conf/panel.ini.

Resolution

  1. Log into Plesk.

  2. Install the extension Panel.ini Editor (if it is not installed already).

  3. Go to Extensions > My Extensions > Panel.ini Editor > Open > Editor.

  4. Add the following lines into the end of the file:

    CONFIG_TEXT: [ext-s3-backup]
    RegionForCustomEndpoint = GRA

    Note: Replace GRA with the name of the region of your S3-compatible storage provider. Also, in some cases, region should be specified in lowercase, gra (clarify this with the storage provider).

  5. Click Save to save the changes.

Was this article helpful?

Comments

2 comments
Date Votes
  • Hi, you will need to write the "RegionForCustomEndpoint" in lowercase.

    For example:

    RegionForCustomEndpoint = gra

     

    0
  • Hello @Ruben Colmenarejo!

    Thank you for information, I have updated the note under step 4 (as different storage providers may have their regions named differently).

    0

Please sign in to leave a comment.