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Could not resolve host: ext.plesk.com due to Plesk server firewall restrictions

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • The Plesk > Extensions page cannot be opened due to the following error:

    PLESK_ERROR: Could not resolve host: ext.plesk.com

  • The curl command is not working on the server:

    # curl google.com

    curl: (6) Could not resolve host: google.com

  • The strace utility and its log file shows the following errors:

    # strace -o /tmp/curlissue -fF curl -v google.com

    curl: (6) Could not resolve host: google.com

    # less /tmp/curlissue

    15408 sendmmsg(4, 0x7fde5b11a110, 2, MSG_NOSIGNAL) = -1 EPERM (Operation not permitted)

  • The ping command is also fails by using IP address or domain names while only localhost can be pinged:

    # ping google.com
    ping: unknown host google.com

    # ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    ping: sendmsg: Operation not permitted

    # ping 127.0.0.1
    PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
    64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.060 ms

    # ping localhost
    PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.070 ms

  • Permission of the /etc/resolv.conf file are correct:

    # ls -lah /etc/resolv.conf
    -rw-r--r-- 1 root root 175 May 26 21:46 /etc/resolv.conf

  • Firewall contains many rules and all policies are set to DROP:

    # iptables -L -n -v | grep -i Chain

    Chain INPUT (policy DROP 0 packets, 0 bytes)
    Chain FORWARD (policy DROP 0 packets, 0 bytes)
    Chain OUTPUT (policy DROP 0 packets, 0 bytes)

Cause

A firewall that resides on the side of the Plesk server blocks the connection to the ext.plesk.com website.

Resolution

Reconfigure the server firewall and allow access to the ext.plesk.com website.

One easy way to do so is to use the instructions in this article:

How to open all ports on local server needed by Plesk for Linux automatically?

If you wish to make port changes manually via the Plesk Firewall, you may refer to the following article for additional details:

How to manage ports and firewall rules on Plesk for Linux server 

A good explanation for managing firewall rules directly via iptables is provided in the following article:

25 Useful IPtable Firewall Rules Every Linux Administrator Should Know

If you are using a different firewall on your Linux server, you should refer to its documentation in order to make the necessary changes.

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