Articles in this section

Cannot access website or Plesk Interface behind the NAT

Plesk for Linux kb: technical ABT: Group A ip address

Applicable to:

  • Plesk for Linux

Symptoms

  • Server configured with Plesk NAT manager and domains are resolved properly to external IP address. However websites are not accessible from outside.

  • tcpdump utility is not showing traffic from external IP addresses on the interface:

    # tcpdump -i eth0 -nl tcp port 80
    tcpdump: listening on any, link-type LINUX_SLL (Linux cooked), capture size 65535 bytes
    0 packets captured
    0 packets received by filter
    0 packets dropped by kernel

Cause

Firewall misconfiguration.

Resolution

  1. Check NAT configuration for proper IP addresses mapping.

  2. Check that there are no firewall restrictions for ports 80 and 443 between the client and the server.

    It can be checked with following commands on the client Linux computer from outside:

    # curl -vvv 203.0.113.2:80 | grep HTTP
    * About to connect() to 203.0.113.2 port 80 (#0)
    * Trying 203.0.113.2...
    HTTP/1.1 200 OK

    # curl -vvv 203.0.113.2:443 | grep HTTP
    * About to connect() to 203.0.113.2 port 443 (#0)
    * Trying 203.0.113.2...
    HTTP/1.1 200 OK

  3. Check that ports are opened using nmap utility on the linux computer from outside:

    # nmap 203.0.113.2 -p80
    PORT STATE SERVICE
    80/tcp open http

    # nmap 203.0.113.2 -p443
    PORT STATE SERVICE
    443/tcp open https

Note: If ports are filtered or closed, it is needed to check Firewall settings on NAT/external Firewall side.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.