Applicable to:
- Plesk for Windows
Symptoms
-
Plesk might be inaccessible with a 500 error message.
-
The following errors might be found in
%plesk_dir%admin\logs\php_error.log
:Click here to expandCONFIG_TEXT: PHP Fatal error: Uncaught Error: Class 'Zend_Log' not found in C:\Program Files (x86)\Parallels\Plesk\admin\plib\Plesk\Log.php:169
CONFIG_TEXT: ERR [panel] PleskComponentNotInstalledException: The component was not installedfile: C:\Program Files (x86)\Plesk\admin\application\admin\controllers\WebAppFirewallController.php
line: 36
code: 0
trace: #0 C:\Program Files (x86)\Plesk\admin\plib\vendor\plesk\zf1\library\Zend\Controller\Action.php(133): Admin_WebAppFirewallController->init()
...
#5 C:\Program Files (x86)\Plesk\admin\htdocs\application.php(15): Plesk\Application_Web->run()
ERR [panel.ui] The component was not installed -
Plesk upgrade or update fails with one of the following errors:
Click here to expandCONFIG_TEXT: Unable to set the object (C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\****) owner: (5) Access is denied.
CONFIG_TEXT: Unable to set the object (C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\****) owner: (2) The system cannot find the file specified.
CONFIG_TEXT: MSI: Error! Critical action 'Configure Plesk site...' failed:
Access is denied. (Error code 5) at Unable to duplicate handle stdin
Failed to install 'C:\ParallelsInstaller\parallels\PANEL-WIN_17.8.11\dist-windows\plesk-site_mu004.msi': Fatal error during installation. (Error code 1603)
CONFIG_TEXT: Upgrading Let's Encrypt extension... Package action: Execute, package: ext-letsencrypt, exec time: 3 sec. desc: "program='[PLESK_INSTALLDIR]\bin\extension.exe'," "command-line='--upgrade-url" "https://ext.plesk.com/packages/f6847e61-33a7-4104-8dc9-d26a0183a8dd-letsencrypt/download?2.8.0-518'," "working-dir=''," "context=''," "arch=''", output=' STDERR:filemng failed: plesk_exec_with_response(C:\Parallels\Plesk\admin\bin\filemng root file_exists C:\Parallels\Plesk\tmp\modF973.tmp) failed: Unable to execute plesk_exec_with_response: Unable to start (C:\Parallels\Plesk\admin\bin\filemng root file_exists C:\Parallels\Plesk\tmp\modF973.tmp) at Plesk impersonation(PipeServer::ServerThread::simpleRunAs line 687) at (zif_plesk_exec_with_response line 1135)
-
ModSecurity might not appear in Tools & Settings and when reinstalling shows the following error messages appear in
%plesk_dir%admin\logs\plesklog_debug.log
:Click here to expandCONFIG_TEXT: Error: Unable to set the object (C:\) owner: (5) Access is denied.
at execute console command --set-security(vconsoleapp::start line 93)
at execute "C:\Program Files (x86)\Plesk\admin\bin\modsecuritymng.exe" --set-security(vconsoleapp::run line 110) - Cannot access Domains > example.com > File Manager:
Click here to expandPLESK_ERROR: Internal error: Unable to find the directory E:\vhosts\example.com\: filemng failed: Unable to execute plesk_exec_with_response: Unable to start ("C:\Program Files (x86)\Parallels\Plesk\admin\bin\filemng.exe" example.com list dirs E:\vhosts\example.com\)<br> at Plesk impersonation(PipeServer::ServerThread::runAs line 752)<br> at (zif_plesk_exec_with_response line 1204)
-
Cannot create new domain or export a database dump in Domains > example.com > Databases >
DBNAME
> Export Dump:Click here to expandPLESK_ERROR: Error: External exception. Unable to encrypt data: Access is denied. (Error code 5) at RegCreateKeyEx subKey=SOFTWARE\Plesk\PSA Config\Config\sym_key
PLESK_ERROR: Error: Access is denied. (Error code 5) at Unable to remove path (C:\Program Files (x86)\Plesk\tmp\{eaef31a5-53c9-11eb-8928-0cc47ae16d6f}) at (RunTime::File::remove line 1473) at execute "C:\Program Files (x86)\Plesk\admin\bin\filemng" test rm "C:\Program Files (x86)\Plesk\tmp\{eaef31a5-53c9-11eb-8928-0cc47ae16d6f}"(RunTime::RunAsUser::run line 214) (Error code 1)
Cause
Antivirus software is blocking access to Plesk files/services during an update/upgrade or component installation.
Resolution
-
Connect to the Plesk server via RDP
-
Uninstall the antivirus software or exclude the
%plesk_dir%
from the antivirus checks. -
Reboot the server.
-
Rerun Plesk update/upgrade from Plesk > Tools and Settings > Updates and Upgrades or via a command-line interface:
C:\> plesk installer --select-release-current --reinstall-patch --upgrade-installed-components
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