Plesk for Windows
kb: technical
ABT: Group B
Applicable to:
- Plesk for Windows
Symptoms
-
After server reboot Plesk is not working:
CONFIG_TEXT: ERROR: Exception: Unable to get administrator password:
The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \.\pipe\P_a4ff0c3e-0a95-4093-9dd6-359842b8e9b9 -
In Event Viewer can be found information that some services were not started due to the error:
CONFIG_TEXT: A timeout was reached (30000 milliseconds) while waiting for the Service_Name to connect
- Сloning may hang with the following error under Event Viewer > System:
CONFIG_TEXT: The PleskStartup service terminated with the following service-specific error:
The environment is incorrect.
Cause
For some services default timeout is not enough.
Resolution
Login to the server via RDP and configure ServicesPipeTimeout:
- Go to Start > Run > type regedit.
- Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.
- With the control folder selected, right-click in the panel on the right and select new DWORD Value.
- Name the new DWORD: ServicesPipeTimeout.
- Right-click ServicesPipeTimeout, and then click Modify.
- Select Decimal, type 80000, and then click OK:
- Restart the server.
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