Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Google Authenticator extension in Plesk declines one-time password that was sent to the mobile phone:
PLESK_ERROR: XXXXXX is not valid
-
Phone number was set correctly and the correct password from the one-time message was entered.
Cause
Incorrect time is set on the server or Google Authenticator is misconfigured
Resolution
Apply one of the following solutions:
-
Check what is the current time for your time zone using any public resources, for example, worldtimeserver.com:
-
Compare it with the current server time in Plesk > Tools & Settings > System Time. If it is different, correct it in Plesk > Tools & Settings > System Time.
-
Make sure that the local time and the timezone on the server match those on the mobile device.
Note: If the time does not change via Plesk UI, the server time need to change directly from the server:
For Windows check the following article How to configure an authoritative time server in Windows Server
For Linux:
- Log in to the server over SSH:
Note: if direct SSH access to the server is not possible, contact server administrator for further assistance.
-
Disable NTP:
# timedatectl set-ntp false
-
Change the timezone Hour/mionites/seconds:
# timedatectl set-time HH:MM:SS
-
Enable ntp:
# timedatectl set-ntp true
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