Articles in this section

Plesk backup fails: No space left on device

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • A backup is finished with one of the following warnings/errors:

    PLESK_INFO: Warning: domain "example.com"
    Not all the data was backed up into /var/lib/psa/dumps/clients/john_doe/domains/example.com successfully.
    Total space: 37287124992;
    Available space: 2109317120;
    Unable to write to the output file '/var/lib/psa/dumps/clients/john_doe/domains/example.com/backup_domainmail_1710251030_1710300108.tgz':
    No space left on device at /usr/local/psa/PMM/agents/shared/Storage/Splitter.pm line 92. pigz: abort: write error on <stdout> (Broken pipe) Broken pipe at /usr/local/psa/PMM/agents/shared/Storage/Storage.pm line 310.


    PLESK_INFO: Warning: mysql "wordpress_0"
    Not all the data was backed up into /var/lib/psa/dumps/domains/example.com/databases/wordpress_0_1 successfully. Total space: 94.00 GB; Available space: 22.00 GB; Mounted on: /. mysqldump: Error: 'Disk full (/var/tmp/#sql_626_2); waiting for someone to free some space...' when trying to dump tablespaces mysqldump: Couldn't execute 'show fields from `hl6UY_commentmeta`': Disk full (/var/tmp/#sql_626_0); waiting for someone to free some space... (1021)


    PLESK_ERROR: STDOUT: Selected filesystem at has only 0 bytes free, but 4096 bytes are needed for operation


    PLESK_ERROR: There is not enough disk space at /var/lib/psa/dumps to backup creation


    PLESK_INFO: Unable to make database dump. Error: Failed to exec mysqldump: Exit code: 5

  • The following errors appear in /usr/local/psa/PMM/logs/backup-2020-05-08-02-33-12-032/backup.log:

    PLESK_ERROR: ERR [panel] PHP Warning: file_put_contents(/var/lib/psa/dumps/backup_info_2005080233.xml): failed to open stream: No space left on device

  • FTP backup cannot be restored with the following error message in /var/log/plesk/panel.log:

    PLESK_INFO: Error: Unable to import file as dump: pmm-ras failed (Error code = 1): STDOUT: boost::filesystem::create_directories: No space left on device: "/tmp/pmm-repo-icon-content-uPBsvu/clients/example/domains/example.com/databases" STDERR:


    PLESK_INFO: ERR [panel] DB query failed: SQLSTATE[HY000]: General error: 1 Can't create/write to file '/var/tmp/#sql_674_0.MAI' (Errcode: 28), query was: DESCRIBE `sessions`:
    0: /usr/local/psa/admin/plib/Db/Adapter/Pdo/Mysql.php:53
    Db_Adapter_Pdo_Mysql->query(string 'DESCRIBE `sessions`')

  • Restoration of a backup located on an FTP server fails with the following error message:

    PLESK_ERROR: Internal error ;-P
    ERROR: Plesk\Exception\Database: DB query failed: SQLSTATE[HY000]: General error: 1 Can&#039;t create/write to file &#039;/var/tmp/#sql_658_3.MAI&#039; (Errcode: 28), query was: DESCRIBE `sessions` (Mysql.php:53)

  • Restoration of database backup fails with the following error message:

    Execution of /opt/psa/admin/sbin/backup_restore_helper --get-server-configuration-errors -warnings /opt/psa/PMM/tmp/pmm-sd-rc-warn-84doCA failed with return code 1.
    Stderr is
    DB query failed: SQLSTATE[HY000]: General error: 1021 Disk full (/tmp/#sql_3b9_0.MAI); waiting for someone to free some space... (errno: 28 "No space left on device"), query was: DESCRIBE clients

  • WordPress site backup via  ‘Back Up / Restore’  functionality fails with the following error message:

    PLESK_INFO: Failed to back up site
    Task is not responding: id=837, pid=2279579, type=ext-wp-toolkit-create-backup

  • Disk space where temporary backup files need to be created is full (or insufficient for the necessary temporary backup files):

    # grep TMP /etc/psa/psa.conf
    DUMP_TMP_D /tmp

    # df -h /tmp
    Filesystem    Size    Used    Avail    Use%    Mounted on
    /dev/dev1     7.1G    7.0G    0.1G     99%     /

Cause

During the execution of the backup creation process, a point is reached where the used free space of the drive tied to the local backup generation process runs out and this halts the backup creation process.

Resolution

The recommended solution is to increase the disk space of the server and specific drives on which temporary backup files are being created and backups are being stored.

Warning: Disk partitioning is not covered by Plesk Technical Support. If you are not familiar with Linux system administering and would like Plesk professionals to handle this task, please contact Plesk Professional Services team.

Note: If a Plesk server is running in a Virtuozzo container (the file /proc/user_beancounters exists on the server) the inode limit can be increased as described in the Virtuozzo article. If you are a container owner, contact your service provider for assistance.

Note: If Plesk server is running in a Vultr virtual machine, it is possible to resize the hard disk of the machine using this Vultr article.

Click on a section to expand

Alternatively, you may free up space for the backup task on the related drives by using these options
  •  
Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.