Applicable to:
- Plesk Onyx for Linux
- Plesk for Linux
Symptoms
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Unable to access Acronis Backup extension in Extension > Acronis Backup. The following error is shown in Plesk UI:
PLESK_ERROR: Error: An error has occurred. Please try again later or contact support.
Access to the extension is possible, but no data is shown and the same error appears when trying to access the backup console from the extension's interface.
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Acronis backup log file
/usr/local/psa/var/modules/acronis-backup/srv/log/main.log
contains following records:CONFIG_TEXT: [INFO] MmsResponse: {"error":{"code":-32000,"message":"Can not found backup plan: "},"id":3969,"jsonrpc":"2.0"} /var/lib/Acronis/AgentCommData/mms-comm/out/a34cb12e-2f3a-4f23-b21f-c0bd08e000ec
[INFO] SrvResponse: {"error": {"code": -32059, "message": "Backup plan is not found."}, "id": "5a5ce6644adc1", "jsonrpc": "2.0"}
[INFO] MmsResponse: {"error":{"code":-32603,"message":"Error code 401 and raw message -
The following error occurs on attempt to start a backup from the Backup Console directly:
CONFIG_TEXT: Backup doesn't start:
Backup failed
None of the items selected for backup were found.
Device example.com
Plan name webcp
What to back up Entire machine
Where to back up -
Log in to cloud.acronis.com works correctly
Cause
The issue happens because a token used for communication with Acronis cloud was marked as 'expired' and then revoked on the cloud side.
This happened because there were no calls from the extension UI to the cloud for a week.
Resolution
Register the server once again with the following steps:
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Log in to Backup Console directly via cloud.acronis.com
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Delete the affected Plesk Server from the console (backups will not be deleted):
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Connect to the server via SSH
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Execute the following command and type the Acronis username and password when requested:
# printf "ACRONIS LOGIN\nUser: "; read USER; printf "Password: \n"; read -s PASS; /usr/lib/Acronis/RegisterAgentTool/RegisterAgent -o register -t cloud -a https://cloud.acronis.com -u $USER -p $PASS
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