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SmarterMail is shown as not configured in Plesk: No process is on the other end of the pipe

Plesk for Windows kb: technical ABT: Group B

Applicable to:

  • Plesk for Windows

Symptoms

  • Unable to configure SmarterMail service via Tools & Settings > Server Components: after specifying the correct credentials no errors occur, however service is still shown as 'Not Configured'.
  • In IIS > Sites > SmarterMail > Bindings SmarterMail is bound only to localhost.
  • On attempt to access SmarterMail interface via http://127.0.0.1:9998 the error below appears:

    CONFIG_TEXT: CONFIG_TEXT: Bad Request - Invalid Hostname
    HTTP Error 400. The request hostname is invalid.

With Plesk Backend Debug enabled, the following error can be found in %plesk_dir%admin\logs\plesklog_debug.log:

CONFIG_TEXT: Plesk Management service pipe communication error: No process is on the other end of the pipe. (Error code 233) at Unable to write to pipe at (Con::OverlappedPipe::beginWrite line 358). Trying to reconnect.

Cause

SmarterMail is not listening on 127.0.0.1.

Resolution

  1. Log into the server via RDP.

    Note: if direct RDP access to the server is not possible, contact server administrator for further assistance.

  2. Go to IIS > Sites > SmarterMail > Bindings.
  3. Add the binding on port 9998 without specifying the Hostname to make it listen on all IP addresses including 127.0.0.1.
    1.png
  4. Go to IIS > Application Pools > SmarterMail > Advanced Settings:
  5. Make sure that  Identity for SmarterMail application pool  is set to the NetworkService:
    2.png

  6. Execute the following command via the command line to open Windows Services Manager:

    C:\> services.msc

  7. Find out SmarterMail Service and restart it.
  8. Configure SmarterMail once again under  Tools & Settings > Server Components
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