kb: technical
ABT: Group A
Plesk Onyx for Windows
Applicable to:
- Plesk for Windows
Symptoms
-
Unable to connect to a Plesk for Windows server over implicit FTPS (using port 990):
CONFIG_TEXT: Response: 530 User cannot log in, home directory inaccessible.
Error: Critical error: Could not connect to server -
FTPS connection directly from the server works correctly.
-
Server is behind NAT.
Cause
Firewall misconfiguration on the NAT device or at an intermediate firewall.
Resolution
Ensure that the following ports are open on the NAT device and all intermediate firewalls:
-
For inbound connections:
- 990 (implicit FTPS control port).
- 21 (explicit FTPS or usual FTP control port).
- Passive port range (usually, the range is 49152-65535).
-
For outbound connections:
- 989 (implicit FTPS data port).
- 20 (explicit FTPS or usual FTP data port).
If Plesk server is on a cloud service, open the ports as described in the below documentation articles:
Additional information
How to configure a passive FTP port range in Plesk for Windows?
Which Ports Need To Be Opened for all Plesk Services to Work with a Firewall?
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