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Log rotation option for Service Plans is greyed out or migration has warning: Unable to set log rotation period different from 'daily' because it is forced on server level

kb: technical ext: migrator Plesk Onyx for Linux ABT: Group B Plesk Onyx for Windows

Applicable to:

  • Plesk Onyx for Linux
  • Plesk Onyx for Windows
  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Unable to set log rotation in Service Plans > service_plan_name > Logs & Statistics > Log Rotation:

    Click Install

  • Log rotation is enabled at server level in Tools & Settings > Server Settings > Log rotate:

    Click Install

  • The subscription migration can fail with the following errors:

    CONFIG_TEXT: Plesk error [1019]: Conflicting log rotation settings were selected. Please set up log rotation either by size or by time."


    CONFIG_TEXT: "Failed to create hosting plan 'Default' Plesk error [1023]: Unable to set maximum number of log file greater that server wide limit 7"


    CONFIG_TEXT: "Failed to create hosting plan 'Default' Plesk error [1023]: Unable to set log rotation period different from 'daily' because it is forced on server level"


    CONFIG_TEXT: Plesk restore report problem:Execution of /usr/local/psa/admin/plib/api-cli/domain.php --update example.com -log-bysize 67108864B -ignore-nonexistent-options failed with return code 1.
    Stderr is
    An error occurred during domain update: An error occurred while updating log rotation settings: Unable to set 'log-bysize' argument's value ('67108864'): Unable to set log rotation period different from 'daily' because it is forced on server level

Cause

Log rotation configured at server level prevents service plans from being configured.

Resolution

  1. Log in to Plesk.
  2. Disable Tools & Settings > Server Settings > Log rotate:
    log.PNG
  3. Enable Service Plans > service_plan_name > Logs & Statistics > Log Rotation:
    log2.PNG
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