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Plesk license is not updated: Request cannot be serviced from the specified IP

Plesk for Linux kb: technical ABT: Group B

Applicable to:

  • Plesk for Linux

Symptoms

  • The following warning is present in Plesk:

    Warning: You are currently operating within the grace period of your product license. To update your product license, select the Retrieve Keys option on the License Information page.

  • The license was billed for the next month.

  • The following error appears in an attempt to retrieve keys at the Tools & Settings > License Information page:

    Request cannot be serviced from the specified IP(s): 203.0.113.2

  • The IP address from the error message is present at the Tools & Settings > IP Addresses page.

  • The bold IP address (main IP address) at the Tools & Settings > IP Addresses page differs from IP address mentioned in the error message.

    203.0.113.45
    203.0.113.2

  • On the ka.plesk.com the license is updated and assigned to the 203.0.113.45 IP address only.

  • The 203.0.113.45 IP address is assigned as main in the psa database:

    # plesk db "select id,ip_address,main from IP_Addresses;"

    +----+-------------+-------+
    | id | ip_address | main |
    +----+-------------+-------+
    | 1 | 203.0.113.45| true |
    | 2 | 203.0.113.2 | false |
    +----+-------------+-------+

  • The 203.0.113.45 IP address is located at the first place in interfaces:

    # ip a

    eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    inet 203.0.113.45/32 brd 203.0.113.45 scope global eth0
    valid_lft forever preferred_lft forever
    inet 203.0.113.2/16 brd 203.0.113.2 scope global eth0:1
    valid_lft forever preferred_lft forever

  • There is IP routing to the 203.0.113.2 on the server:

    # ip route

    default via 203.0.113.45 dev eth0
    203.0.113.00/16 dev eth0 proto kernel scope link src 203.0.113.2

  • Sending pings to ka.plesk.com from the server:

    # ping ka.plesk.com

    PING ka.plesk.com (195.214.233.81) 56(84) bytes of data.
    64 bytes from ka.plesk.com (195.214.233.81): icmp_seq=1 ttl=47 time=23.9 ms

    and catching requests via the tcpdump utility:

    # tcpdump ip proto 1 -nl

    18:37:35.866266 IP 203.0.113.2 > 195.214.233.81: ICMP echo request, id 30311, seq 5, length 64
    18:37:35.890322 IP 195.214.233.81 > 203.0.113.2: ICMP echo reply, id 30311, seq 5, length 64

    shows that requests to ka.plesk.com are sent from the server via the 203.0.113.2 which is mentioned in the initial error message.

Cause

Requests to ka.plesk.com are sent from 203.0.113.2 non-main IP address.

Resolution

Contact the system administrator in order to make requests to ka.plesk.com be sent from main 203.0.113.45 IP address.

Feedback
The workaround (In /etc/netplan config file, add option "from" to the section routes): 1. vi /etc/netplan/01-netcfg.yaml routes: - on-link: true to: 0.0.0.0/0 via: 100.200.254.1 from: 100.200.254.100 2. # netplan try

Additional information

Unable to install Plesk license: Request cannot be serviced from the specified IP

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