Applicable to:
- Plesk for Linux
Symptoms
-
SSL/TLS Support option is disabled for the domain in Plesk > Domains > example.com > Dashboard > Hosting & DNS > Hosting
-
A Plesk Admin, Customer or Reseller receives email notifications regarding the Let's Encrypt certificate renewal failure:
CONFIG_TEXT: Could not secure domains of Administrator (login admin) with
Let`s Encrypt certificates. Please log in to Plesk and secure the domains
listed below manually.
Securing of the following domains has failed:
* example.com
The following domains have been secured without some of their Subject
Alternative Names:
<none>
Cause
According to the database, example.com
has a certificate assigned. The certificate_id
value is not 0:
# plesk db "select domains.id, domains.name, hosting.certificate_id from domains left join hosting on domains.id=hosting.dom_id where hosting.certificate_id is not null and domains.name like '%example.com%'"
+----+-------------+----------------+
| id | name | certificate_id|
+----+-------------+----------------+
| 6 | example.com | 104 |
+----+-------------+----------------+
Thus, the keep-secured
task attempts to renew the certificate for example.com
.
Looks like a bug, however, it can not be reproduced on a test server. Create 3rd-line on next reuse
Resolution
-
Go to Plesk > Domains > example.com > Dashboard > Hosting & DNS > Hosting
-
Enable the option SSL/TLS support
-
Set the Certificate value to Not Selected
-
Click OK to apply changes
-
Uncheck the SSL/TLS Support option back to disable it and apply changes.
Note: Notifications can be sent with a delay up to 1 day, so it is possible that notification will still be received the next day
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