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Old public IP address is shown in Plesk after changing the public IP address on a cloud service side

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Old public IP address is shown for a domain in Plesk at Domains > example.com page or when plesk login command is used:

    mceclip0.png

  • A new public IP address has been assigned on a cloud service side.

Cause

The new public IP address has not been updated for a server private IP address at Tools & Settings > IP Addresses page.

Resolution

  1. Log into Plesk using the new public IP address.

  2. Go to Tools & Settings > IP Addresses > 192.0.2.2 page.

  3. Change Public IP address to a new one and click OK to apply the changes.

Note: 192.0.2.2 is an example of a private IP address. Replace it with your own.

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Comments

1 comment
Date Votes
  • Hi Alexander Davydov,

     

    To the best of my memory, I currently got the opposite direction where the NEW Private IP was set as if it the Public IP, not enabling me to set the New public IP.

    Even if I added a new correct second setting, I could NOT remove the wrong one. It took me lot of struggle to somehow manage to get the setting changed, possibly through one of the plesk repair all -y calls.

    Also, I would prefer configuring instance 'conf' files (i.e., nginx, etc.) using the Public IP so I won't have to look for various changes when the Private IP is switched, as a byproduct of a SNAPSHOT full server restore, if possible for Plesk to enable such configuration.

    The above may include the setting of the IP linked to the host in the 'conf' file: /etc/hosts

     

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