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Can't connect via FTP: 530 User cannot log in, home directory inaccessible

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Unable to connect to a domain on Plesk over FTP

    Response: 530 User cannot log in, home directory inaccessible.
    Error: Critical error: Could not connect to the server

  • Repairing the FTP server shows the domain resolves to a different IP address

    # plesk repair ftp -y
    Checking all domain names resolve to appropriate IP addresses
    The domain name example.com resolves to another IP address (203.0.113.2) ... [WARNING]

  • The server has several IP addresses

Cause

The wrong IP address is assigned to the domain in its hosting settings.

Resolution

  1. Log in to Plesk

  2. Go to Domains > example.com > Hosting & DNS > Hosting

  3. Select the IP address that actually resolves to the domain

  4. Press OK to save the changes

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