Articles in this section

Repeating error in panel.log: Unable to get key: Repository is not opened

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

The following error repeats multiple times in /var/log/panel.log whenever the server's license information is updated (for example, during the Daily Maintenance Task):

ERR [panel] Unable to get key: Repository is not opened

Cause

Corrupted /etc/sw/keys/registry.xml file.

Resolution

Regenerate the corrupted file:

  1. Connect to the server via SSH

  2. Remove the file:

    # rm -f /etc/sw/keys/registry.xml

  3. Regenerate it with Plesk repair tool:

    # plesk repair fs -y

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.