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Unable to open Plesk or a website or log in to an email account from a specific IP address: ERR_CONNECTION_TIMED_OUT

Plesk for Linux kb: technical ABT: Group B

Applicable to:

  • Plesk for Linux

Symptoms

  • Fail2Ban is installed and enabled in Plesk.

  • When opening Plesk or a website or logging in to an email account via webmail from a specific IP address (for example, 203.0.113.2), the connection fails:

    CONFIG_TEXT: ERR_CONNECTION_TIMED_OUT


    CONFIG_TEXT: ERR_CONNECTION_REFUSED


    CONFIG_TEXT: This site can’t be reached
    203.0.113.2 took too long to respond.

  • From other IP addresses Plesk, websites and email accounts are accessible.

  • The following error message may appear in Plesk during some operation:

    PLESK_ERROR: Request to backend API failed with error: Network error

  • The IP address 203.0.113.2 can be found in Plesk at Tools & Settings > IP Address Banning (Fail2Ban) > Banned IP Addresses or via CLI:

    # plesk bin ip_ban --banned
    Banned IP addresses:
    203.0.113.2 plesk-panel Jan 1, 2020

Cause

The user's IP address has been banned by Fail2Ban.

Resolution

Unban the IP-address or add it to trusted IP-addresses

 

Unbanning the blocked IP address via Plesk

 

  1. Log in to Plesk from a different IP address (another device).

  2. Go to Tools & Settings > IP Address Banning (Fail2Ban) > Banned IP Addresses.

  3. Select the user's IP address and click Unban or Move to Trusted IPs.

 

Unbanning the blocked IP address via a command-line interface

 

  1. Connect to the Plesk server via SSH.

  2. Unban the user's IP address:

    # plesk bin ip_ban --unban 203.0.113.2
    SUCCESS: The selected IP addresses were unbanned.

  3. Add the IP address to the list of trusted IP addresses:

    # plesk bin ip_ban --add-trusted 203.0.113.2

 

Additional Information

To find out why an IP address got banned by Fail2Ban, see this KB article.

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