Articles in this section

Unable to issue a Let's Encrypt certificate for a domain in Plesk when SSL/TLS support is disabled

kb: bug Plesk for Windows Plesk for Linux ext: le ABT: Group B

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • The following warning is displayed in Plesk at Domains > example.com > SSL/TLS Certificates:

    PLESK_WARN: Warning: SSL/TLS support is disabled for example.com.
    To resolve the issue, please enable to SSL/TLS support ("Websites & Domains" > "Hosting Settings") for this domain and try again.

  • The "Get it free" button is greyed out or it is only possible to secure webmail for a domain (other options are missing) at Domains > example.com > SSL/TLS Certificates > Install:


    Screenshot_2020-06-16_SSL_TLS_Certificate_for_example_com_-_Plesk_Obsidian_18_0_27.png

     

Cause

You cannot install an SSL certificate when SSL/TLS support is disabled. The behavior when there is no warning about disabled SSL support is considered a bug with ID #EXTLETSENC-871.

Resolution

  1. Log in to Plesk.
  2. Go to Domains > example.com > Hosting Settings.
  3. Enable SSL/TLS support.
  4. Apply the changes.
Was this article helpful?

Comments

1 comment
Date Votes
  • Somehow it doesn't work for me have done what you said like it's enabled. And have selected the default key. Somehow my https stay unsecured. Have plesk with my strato server. It advertises having 1 free encrypt. But don't get it fixed, the option for free encrypt isn't available for me.

    0

Please sign in to leave a comment.