Как переустановить пакет ModSecurity

Создана:

2016-11-16 13:10:18 UTC

Изменена:

2017-08-16 17:35:42 UTC

1

Помогла ли вам статья?


Есть вопросы?

Отправить запрос

Как переустановить пакет ModSecurity

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Симптомы

Как переустановить пакет ModSecurity из репозитория Plesk?

Решение

Для RedHat-систем:

  1. Получите список установленных пакетов ModSecurity :

    # rpm --query --all | grep security
  2. Удалите существующие пакеты. Например:

    # rpm --erase mod_security-2.8.0-14080716.x86_64 plesk-modsecurity-configurator-12.0.18-cos7.build1200140811.16.noarch plesk-modsecurity-crs-12.0.18-14070712.x86_64

Перейдите на шаг 3 ниже.

Для Debian-систем:

  1. Получите список установленных пакетов ModSecurity :

    # dpkg --list *modsecurity*
  2. Удалите существующие пакеты:

    # dpkg --remove libapache2-modsecurity plesk-modsecurity-configurator plesk-modsecurity-crs
  3. Запустите автоустановщик Plesk через графический интерфейс или командную строку, затем снова установите компонент ModSecurity. Компонент находится в разделе Web hosting features .

  4. Сохраните настройки по умолчанию на странице Инструменты и настройки > Брандмауэр для веб-приложений (ModSecurity) для настройки модуля.

Была ли эта статья полезной?
Пользователи, считающие этот материал полезным: 1 из 3
Еще есть вопросы? Отправить запрос
Войдите в службу, чтобы оставить комментарий.