Не удается войти в Parallels Plesk Panel из-за ошибки 'Unable to connect to pipe \\.\pipe\psapipe'

Создана:

2016-11-16 13:02:56 UTC

Изменена:

2017-06-19 18:23:34 UTC

2

Помогла ли вам статья?


Есть вопросы?

Отправить запрос

Не удается войти в Parallels Plesk Panel из-за ошибки 'Unable to connect to pipe \\.\pipe\psapipe'

Applicable to:

  • Plesk for Windows

Симптомы

При попытке войти в Parallels Plesk Panel возникает следующая ошибка:

ERROR: Exception The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\.\pipe\psapipe 0: constants.php3:62 get_admin_password() 1: constants.php3:62 require_once(string 'C:\Program Files (x86)\Parallels\Plesk\admin\plib\constants.php3') 2: auth.php3:100

В то же время Parallels Plesk Panel создает следующее системное событие:

The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\.\pipe\psapipe
   at (Con::ClientOverlappedPipe::create line 502)
   at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 257)
   at execute console command --direct-sql(vconsoleapp::start line 132)
   at execute dbclient.exe --direct-sql "--sql=select * from misc"(vconsoleapp::run line 143)
Execute file name: C:\Program Files (x86)\Parallels\Plesk\admin\bin\dbclient.exe

Причина

Недоступна база данных Parallels Plesk Panel.

Решение

1. Посмотрите, какой провайдер баз данных используется для хранения Parallels Plesk Panel, в кусте HKLM\SOFTWARE\Wow6432Node\Plesk\PSA Config\Config\PLESK_DATABASE_PROVIDER_NAME системного реестра:

Смотрите статью 3453 -- Как определить, какой провайдер БД используется для хранения базы данных PP

2. Определите статус соответствующей службы:

C:\>sc query PleskSQLServer

SERVICE_NAME: PleskSQLServer
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 1  STOPPED
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

3. Запустите ее:

sc start PleskSQLServer

4. Выполните диагностику и устранение проблем, возникших во время запуска.

Была ли эта статья полезной?
Пользователи, считающие этот материал полезным: 2 из 17
Еще есть вопросы? Отправить запрос
Войдите в службу, чтобы оставить комментарий.