Как обновить версию PHP на Debian?

Создана:

2016-11-16 12:51:27 UTC

Изменена:

2017-08-16 18:34:46 UTC

25

Помогла ли вам статья?


Есть вопросы?

Отправить запрос

Как обновить версию PHP на Debian?

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Вопрос

Как обновить PHP до версии 5.4/5.5/5.6 на Debian?

Ответ

Примечание. Plesk официально поддерживает пакеты, поставляемые вместе с ним, пакеты системы и пакеты из официальных репозиториев системы.

Если в официальных репозиториях вашей системы нет более новых версий пакетов PHP, их придется собрать вручную или установить из сторонних репозиториев.

Такое обновление PHP является исключительно административной задачей и должно выполняться вашим локальным администратором. По этой операции поддержка службой поддержки Plesk не предоставляется.

Здесь мы приводим всего лишь пример того, как можно обновить PHP на Debian с помощью стороннего репозитория:

  1. Добавьте главный репозиторий в свой список sources.list.

    В зависимости от вашего дистрибутива (Jessie, Wheezy или Squeeze), добавьте эти две строки в файл /etc/apt/sources.list (вы также можете выбрать ближайшее к вам зеркало) :

    deb http://packages.dotdeb.org jessie all
    deb-src http://packages.dotdeb.org jessie all

    или

    deb http://packages.dotdeb.org wheezy all
    deb-src http://packages.dotdeb.org wheezy all

    или

    deb http://packages.dotdeb.org squeeze all
    deb-src http://packages.dotdeb.org squeeze all
  2. Опции:

    Если вы хотите установить:
    PHP 5.6 на Debian 7 “Wheezy” (без Zend Thread Safety), также добавьте эти две строки:

    deb http://packages.dotdeb.org wheezy-php56 all
    deb-src http://packages.dotdeb.org wheezy-php56 all

    PHP 5.6 на Debian 7 “Wheezy” (с Zend Thread Safety), добавьте эти две строки:

    deb http://packages.dotdeb.org wheezy-php56-zts all
    deb-src http://packages.dotdeb.org wheezy-php56-zts all

    PHP 5.5 на Debian 7 “Wheezy”, также добавьте эти две строки:

    deb http://packages.dotdeb.org wheezy-php55 all
    deb-src http://packages.dotdeb.org wheezy-php55 all

    PHP 5.4 на Debian 6 “Squeeze”, также добавьте эти две строки:

    deb http://packages.dotdeb.org squeeze-php54 all
    deb-src http://packages.dotdeb.org squeeze-php54 all
  3. Получите и установите ключ GnuPG:

    wget http://www.dotdeb.org/dotdeb.gpg
    sudo apt-key add dotdeb.gpg
  4. Установите:

    apt-get update  
    apt-get install php5

Примечание. Не перечисленные версии PHP придется собирать вручную. В случае возникновения каких-либо проблем при сборке и установке PHP из сторонних репозиториев, пожалуйста, смотрите документацию PHP или обратитесь к своему локальному администратору за поддержкой.

Была ли эта статья полезной?
Пользователи, считающие этот материал полезным: 25 из 77
Еще есть вопросы? Отправить запрос

1 Комментарии

Войдите в службу, чтобы оставить комментарий.