Notifications sent to the external email domain are not being sent: Error sending the report

Создана:

2016-11-16 12:43:17 UTC

Изменена:

2017-06-05 05:46:57 UTC

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Notifications sent to the external email domain are not being sent: Error sending the report

Applicable to:

  • Plesk 12.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 11.0 for Windows

Symptoms

Plesk mail notifications sent to the external e-mail address are not sent.

One of the following errors may be shown:

  • in %plesk_dir%\admin\logs\php_error.log :

    Error: Error sending the report: Sender address is not valid for your login. Check your email program settings.
    
  • in %plesk_dir%\MailServers\MailEnable\Logging\SMTP :

    05536E3B2E4D59.MAI      1268    127.0.0.1       MAIL    MAIL FROM:<user@sender.tld>   250 Requested mail action okay, completed       43      31              
    SMTP-IN 7F87DB65F5EA4569B105536E3B2E4D59.MAI    1268    127.0.0.1       RCPT    RCPT TO:<user@recipient.tld>
    503 This mail server requires authentication when attempting to send to a non-local e-mail address. Please check your mail client settings or contact your administrator to verify that the domain or address is defined for this server.
    235    Failed to meet all relay criteria. Attempt to relay to [SMTP:user@receiver.tld] was denied for requesting IP Address 127.0.0.1 
    
  • in Event Viewer:

    SMTP Exception
    at Unable to execute event(runtask::start line 210)
    Execute file name: C:\Program Files (x86)\Parallels\Plesk\admin\bin\runtask.exe
    
  • in %plesk_dir%\admin\logs\health-alarm.log :

    Unable to send e-mail notification: Could not read from <domainname>
    

Cause

  • Authenticated senders must use valid sender address option is enabled in MailEnable. If it is selected, users with authentication to send email must configure their email client with a valid email address that is assigned to the mailbox they are using to send on. This option is useful to force clients to use a legitimate email address, thereby reducing the possibility of spam.

  • Allow Relay For Privileged IP Ranges rights have not been set or 127.0.0.1 is not listed in the range of IP addresses.

Resolution

  1. Make sure that IP address of the external SMTP server is added in the hosts file.

  2. Disable Authenticated senders must use valid sender address feature in MailEnable Administration console > Servers > Localhost > Connectors > SMTP Properties > Security tab .

  3. Enable Allow Relay For Privileged IP Ranges and ensure, that 127.0.0.1 is listed in the Privileged IPs list.
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