Plesk において Apache で PHP-FPM を使用するには

Created:

2016-11-16 13:22:21 UTC

Modified:

2017-08-16 16:58:18 UTC

1

Was this article helpful?


Have more questions?

リクエストを送信

Plesk において Apache で PHP-FPM を使用するには

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

症状

PHP ハンドラ FPM application served by Apache Plesk > Domains > example.com > PHP Settings にありませんが、 Plesk > Tools & Settings > PHP Settings では有効化されています。

原因

FPM application served by Apache ハンドラは Apache バージョン 2.4 から使用可能になっています。

解決策

CentOS 6 には Apache バージョン 2.2 が付属しますが、 FPM application served by Apache は使用できません。

考えられる回避策は、CentOS 7 へのサーバマイグレーションです。この OS には Apache バージョン 2.4 がインストールされています。

FPM application served by nginx の使用が可能です。

これを有効化するには、以下の手順に従います。

  1. Plesk 自動インストーラを実行します。

    /usr/local/psa/admin/sbin/autoinstaller
  2. Main components list for Plesk で、 Web hosting > Nginx web server and reverse proxy server を選択し、以下のコンポーネントを選択してインストールします。

    1. [*] Nginx web server
    2. [*] PHP-FPM support from OS vendor
他にご質問がございましたら、リクエストを送信してください
ログインしてコメントを残してください。