SSL が機能していません:write:errno=104 no peer certificate available No client certificate CA names sent

Created:

2016-11-16 13:22:10 UTC

Modified:

2017-08-16 22:25:34 UTC

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SSL が機能していません:write:errno=104 no peer certificate available No client certificate CA names sent

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux

症状

以下のエラーメッセージにより、SSL へ接続することができません。

# openssl s_client -connect <address>:993 -crlf
CONNECTED(00000003)
write:errno=104
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 0 bytes and written 249 bytes
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE

または

# openssl s_client -connect <address>:995 -crlf
CONNECTED(00000003)
write:errno=104
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 0 bytes and written 247 bytes
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE

原因

IMAP/POP3 サーバに対して正しくない証明書が使用されています。

解決策

  1. どの証明書が Courier-IMAP で使用されているか確認します。

    # grep 'TLS_CERTFILE' /etc/courier-imap/imapd-ssl
    TLS_CERTFILE=/usr/share/courier-imap/imapd.pem

    # grep 'TLS_TRUSTCERTS' /etc/courier-imap/pop3d-ssl
    TLS_TRUSTCERTS=/usr/share/courier-pop3d/pop3d.pem
  2. この証明書の内容を確認します。

    # cat /usr/share/courier-imap/imapd.pem
    -----BEGIN DH PARAMETERS-----
    MEYCQQCNzLSn7W8kIu6jgtc9W9i5Bz5uft2xlVegIOqZscP+MYcXm7jU0wstUKUP
    b9UZJmSGAIiIM/qK9aHCBA9w5cYjAgEC
    -----END DH PARAMETERS-----

    正しい証明書は先頭と末尾が以下のようになっている必要があります(一例)。

    -----BEGIN CERTIFICATE-----
    MIIB8TCCAZsCBEUpHKkwDQYJKoZIhvcNAQEEBQAwgYExCzAJBgNVBAYTAlJPMQww
    ............
    ............
    eNpAIeF34UctLcHkZJGIK6b9Gktm
    -----END CERTIFICATE-----
    -----BEGIN RSA PRIVATE KEY-----
    MIICXgIBAAKBgQDv6i/mxtS2B2PjShArtOAmdRoEcCWa/LH1GcrbW14zdbmIqrxb
    ..........
    ..........
    faXRHcG37TkvglUZ3wgy6eKuyrDi5gkwV8WAuaoNct5j5w==
    -----END RSA PRIVATE KEY-----
  3. この構成を変更して、 /usr/share/imapd.pem にあるデフォルト証明書を使用するようにします(古い証明書はコメントアウトします)。

    grep 'TLS_CERTFILE' /etc/courier-imap/imapd-ssl
    ...
    #TLS_CERTFILE=/usr/share/courier-imap/imapd.pem
    TLS_CERTFILE=/usr/share/imapd.pem

    grep 'TLS_CERTFILE' /etc/courier-imap/pop3d-ssl
    #TLS_TRUSTCERTS=/usr/share/courier-pop3/pop3d.pem
    TLS_TRUSTCERTS=/usr/share/pop3d.pem
    1. Courier-IMAP および Courier-POP3 サービスを再起動します。

      service courier-imapd restart

      Stopping Courier IMAP server: [ OK ]Starting Courier IMAP server: [ OK ]

      /etc/init.d/courier-imaps restart

      Stopping Courier IMAP server with SSL/TLS support: [ OK ]Starting Courier IMAP server with SSL/TLS support: [ OK ]

      service courier-pop3s restart

      Stopping Courier POP3 server with SSL/TLS support: [ OK ]Starting Courier POP3 server with SSL/TLS support: [ OK ]

      service courier-pop3d restart

      Stopping Courier POP3 server: [ OK ]Starting Courier POP3 server: [ OK ]

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