Plesk のアップグレードが "ERROR 1524 (HY000): Plugin 'Y' is not loaded" で失敗しました

Created:

2016-11-16 13:07:49 UTC

Modified:

2017-08-16 16:28:37 UTC

0

Was this article helpful?


Have more questions?

リクエストを送信

Plesk のアップグレードが "ERROR 1524 (HY000): Plugin 'Y' is not loaded" で失敗しました

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

症状

Plesk のアップグレードが以下のエラーで失敗しました。

ERROR 1524 (HY000): Plugin 'Y' is not loaded

/var/log/mysqld.log ログに、以下の警告メッセージが表示されます。

150824 20:12:02 [Warning] 'user' entry 'pma_YDHnd4Ja5pfe@localhost' has both a password and an authentication plugin specified. The password will be ignored.

原因

mysql データベースの値が正しくありません。

解決策

  1. mysql データベースのバックアップを作成します。

    mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` mysql > mysql.sql
  2. 言及されているユーザの plugin の値を確認します。

    mysql> select plugin from mysql.user where User like '%pma_YDHnd4Ja5pfe%' \\G
    *************************** 1. row ***************************
    plugin: Y
    1 row in set (0.00 sec)
  3. 以下のクエリによって、正しくない値を削除します。

    mysql> update mysql.user set plugin = '' where User like '%pma_YDHnd4Ja5pfe%';
    Query OK, 1 row affected (0.01 sec)
    Rows matched: 1 Changed: 1 Warnings: 0
他にご質問がございましたら、リクエストを送信してください
ログインしてコメントを残してください。