Cannot open File Manager: "502 bad gateway"

Created:

2016-11-16 12:49:41 UTC

Modified:

2017-08-16 16:52:28 UTC

0

Was this article helpful?


Have more questions?

リクエストを送信

Cannot open File Manager: "502 bad gateway"

Applicable to:

  • Plesk 11.5 for Linux
  • Plesk Automation 11.5

Symptoms

When attempting to browse a domain using File Manager, Nginx shows the following error:

502 bad gateway

The following error appears in /var/log/sw-cp-server/error_log :

[error] 22141#0: *5765 upstream sent too big header while reading response header from upstream, client: 10.30.87.27, server: , request: "GET /smb/file-manager/list?currentDir=/%2Fhttpdocs HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock:", host: "example.com:8443", referrer: "https://example.com:8443/smb/web/view"

Cause

The issue is triggered by the existence of a large number of files in the directory that you tried to open.

Resolution

This issue has been completely fixed since Parallels Plesk 11.5.30 MU #25 . Please install the latest Micro-Updates on the server to fix the issue.

Workaround

For earlier releases of Parallels Plesk 11.5, the following workaround can be applied:

  1. Back up the original configuration file:

    # cp -p /etc/sw-cp-server/config /etc/sw-cp-server/config.backup.`date +%F`
    
  2. Increase the FastCGI buffer size to resolve the issue as below:

    # cat /etc/sw-cp-server/config|grep 'fastcgi_buffer'
    fastcgi_buffers 128 2048k;
    fastcgi_buffer_size 2048k;
    
他にご質問がございましたら、リクエストを送信してください
ログインしてコメントを残してください。