OS アップデートから Apache を最新バージョンにアップグレードすることは可能かどうか

Created:

2016-11-16 13:20:52 UTC

Modified:

2017-08-16 18:25:58 UTC

0

Was this article helpful?


Have more questions?

リクエストを送信

OS アップデートから Apache を最新バージョンにアップグレードすることは可能かどうか

Applicable to:

  • Plesk 12.0 for Linux

Resolution

コントロールパネルのインターフェース自体は、ポート 8443 8880 にある独立した特別なサービスだけが提供しています。 Parallels Plesk Panel のバージョン 7.x 8.x httpsd サービス (ベースはカスタマイズした apache コンパイル) を使用しており、バージョン 9.x sw-cp-server サービス (ベースはカスタマイズした lighttpd コンパイル) を使用して、コントロールパネルにサービスを提供しています。 これらのサービスを変更することはできません。

ただし Plesk 内のウェブサイトは、 OS ディストリビューションの一部であるレギュラーシステム apache でホスティングされています。 それは、この OS ベンダーの、この OS の適切な apache アップデートを用いて自由にアップデートできます。


Parallels Plesk Panel バージョン 7.x では、 Apache パッケージをアップグレードした後に /usr/sbin/suexec ファイルを手動で置き換える必要があります。以下のコマンドを使って置き換えることができます :

~# cp /usr/local/psa /suexec/psa-suexec /usr/sbin/suexec
~# chown root:apache /usr/sbin/suexec
~# chmod 4510 /usr/sbin/suexec

/usr/local/psa $PRODUCT_ROOT_D です。

: 7.5.4 より古いバージョンの Parallels Plesk Panel では、 psa-suexec /usr/sbin/psa-suexec 内にあります。

バージョン 8.x 9.x では、 Parallels Plesk Panel はトリガーを置いて、 Apache パッケージをアップグレードした後に suexec を置き換えます。 CentOS ではトリガーは以下のようになります :

---8<---
cp -f /usr/local/psa /suexec/psa-suexec /usr/sbin/suexec
chown root:apache /usr/sbin/suexec
chmod 4510 /usr/sbin/suexec
--->8---


従って、 Parallels Plesk Panel 8.x 9.x では、 Apache パッケージをアップグレードした後に /usr/sbin/suexec を置き換える必要はありません。

Keywords: how do i upgrade apache httpd

他にご質問がございましたら、リクエストを送信してください
ログインしてコメントを残してください。