Virtuozzo containers 内で Plesk のリソース超過が発生します

Created:

2016-11-16 13:11:03 UTC

Modified:

2017-05-23 17:48:05 UTC

7

Was this article helpful?


Have more questions?

リクエストを送信

Virtuozzo containers 内で Plesk のリソース超過が発生します

症状

症状は様々ですが、この問題は Virtuozzo containers(旧名 Parallels Virtuozzo Container - PVC)のみで発生します。Plesk またはシステムサービスが起動しないか、誤作動またはクラッシュします。

原因

コンテナに十分なリソースが割り当てられていません。

診断

注: *本記事では、Virtuozzo containers での UBC リソース管理モデルについてのみ言及します。旧バージョンの PVC(3.0~4.6 を含む)のコンテナは、SLM モードまたは両モードで実行していた可能性があります。この場合、SLM メモリの使用状況をチェックする必要があります。このチェックを完了するには、Virtual Automation(旧名 Parallels Virtual Automation - PVA)のウェブインターフェースを使用することをお勧めします。SLM について詳しくは、PVC のマニュアルを参照してください。

ここでは、例としてコンテナで Apache の起動が失敗したとします。

この問題の原因がリソース不足かどうかを確認します。

  1. コンテナに SSH ログインし、以下のコマンドを実行してユーザビーンカウンタ(UBC)の現在の状態を記録します。

    # cat /proc/user_beancounters > before_failure.txt
  2. 問題を再現します(Apache の起動を試みます)。

  3. 以下のコマンドを実行して、UBC の新しい状態を記録します。

    # cat /proc/user_beancounters > after_failure.txt
  4. 2 ファイル( before_failure.txt および after_failure.txt )を開き、' failcnt ' 列の値を確認します。いずれかの値が増加していた場合、特定のリソースが不足しています。この場合、以下の解決策に従ってください。

解決策

VA を使用するか、ハードウェアノードで以下のコマンドを実行して、コンテナの当該 UBC のリミット値を引き上げます。

    # vzctl set <CT_ID> --save --<RESOURCE_NAME> <BARRIER>:<LIMIT>

ここで、

<CT_ID> - コンテナ ID です。

<RESOURCE_NAME> - リソース名です(user_beancounters ファイルで確認可能)

<BARRIER> - リソースの新しいバリア値(ソフトリミット)(現在の値は、user_beancounters ファイルで確認可能)

<LIMIT> - リソースの新しいリミット値(ハードリミット)(現在の値は、user_beancounters ファイルで確認可能)

注: 一部のリソース設定では、異なるフォーマットが必要になります。"vzctl --help" コマンドを実行して確認するか、 Virtuozzo containers マニュアル を参照してください。

他にご質問がございましたら、リクエストを送信してください
ログインしてコメントを残してください。