Google アカウントでの AuthSub のサポートは終了しています。これにより Google サービスと Presence Builder の間のインタラクションに影響はあるのでしょうか?

Refers to:

  • Plesk for Linux
  • Web Presence Builder for Linux

Created:

2016-11-16 12:45:03 UTC

Modified:

2016-12-21 19:07:41 UTC

0

Was this article helpful?


Have more questions?

リクエストを送信

Google アカウントでの AuthSub のサポートは終了しています。これにより Google サービスと Presence Builder の間のインタラクションに影響はあるのでしょうか?

症状

公式発表 によると、Google アカウントでの AuthSub のサポートは終了しています。

このことは、Presence Builder から Google サービスへのアクセスに影響を与えるのでしょうか?

解決策

Presence Builder のユーザは、Presence Builder からの AuthSub 認証が必要となる複数の Google サービスをサイトで使用できます。

  • Google アナリティクス
  • Picasa ウェブアルバム

2015 年 4 月 20 日をもって Google は AuthSub のサポートを終了しているため、モジュールの動作でエラーが発生する可能性があります。

注: Picasa ウェブアルバムを使用する既存のサイトは、再発行後も正常に動作を続けます。

Presence Builder でのエラーを回避するには、以下の回避策を適用してください。Presence Builder ユーザに対し、Google サービスをオフにします。

  1. Presence Builder サーバで、 /usr/local/sb/config ファイルの [general] セクションに以下の行を追加します。

    # vi /usr/local/sb/config
    [general]
    ...
    google_analytics_enabled = false
    picasa_enabled = false
    ...

    注:OSA にインストールした Presence Builder では、root ディレクトリがデフォルトと異なります。以下を実行します。

    # find / -name "SB"

    Presence Builder のディレクトリの場所を確認できます。

    1.1. 上記の手順で解決せず、引き続きエラーが発生する場合、以下のサービスもオフにしてください。

    • Google Fonts
    • Google Maps
    • Google site search
      # vi /usr/local/sb/config
      [general]
      ...
      google_search_enabled = false
      google_fonts_enabled = false
      hidden_widgets= map
      ...

    1.2. また、お使いの Presence Builder が(12.0.6 や 12.0.5 ではなく)12.0.7 である場合、 手順 1 を完了し、Google サービスをオフにした後で、以下の パッチ を適用する必要があります。

    1. パッチをダウンロードします。

      # wget http://kb.plesk.com/Attachments/kcs-50014/ppb_12.0.7_patch_4435.zip
    2. パッチを展開します。

      # unzip ppb_12.0.7_patch_4435.zip
    3. 以下のファイルをバックアップします。

      # cp /usr/local/sb/htdocs/js/minimized/Editor.js{,.orig}
      # cp /usr/local/sb/htdocs/js/Sb/editor/SettingsPanel.js{,.orig}
    4. これらのファイルを、添付のファイルに置き換えます。

      # cp htdocs/js/minimized/Editor.js /usr/local/sb/htdocs/js/minimized/Editor.js
      # cp htdocs/js/Sb/editor/SettingsPanel.js /usr/local/sb/htdocs/js/Sb/editor/SettingsPanel.js

注: インストールした製品を常に最新バージョンに保つことをお勧めします。お使いの Presence Builder のバージョンが 12.0.7 ではない場合、 マニュアル に従って最新のアップデートをすべてインストールしてください。

他にご質問がございましたら、リクエストを送信してください
ログインしてコメントを残してください。