Cómo usar PHP-FPM con Apache en Plesk

Created:

2016-11-16 13:22:21 UTC

Modified:

2017-08-16 16:58:18 UTC

1

Was this article helpful?


Have more questions?

Enviar una solicitud

Cómo usar PHP-FPM con Apache en Plesk

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Síntomas

El controlador PHP FPM application served by Apache no aparece en Plesk > Dominios > example.com > Configuración PHP , si bien este está activado en Plesk > Herramientas y configuración > Configuración PHP .

Causa

El controlador FPM application served by Apache está disponible a partir de Apache 2.4.

Resolución

Como CentOS 6 incluye Apache 2.2, no es posible usar FPM application served by Apache .

Como solución provisional, migre un servidor a CentOS 7, ya que este SO ya tiene instalado Apache 2.4.

Es posible usar FPM application served by nginx .

Para activarlo, realice lo siguiente:

  1. Ejecute Plesk autoinstaller:

    /usr/local/psa/admin/sbin/autoinstaller
  2. En Main components list for Plesk , seleccione Web hosting > Nginx web server and reverse proxy server > seleccione e instale los siguientes componentes:

     1. [*] Nginx web server
    2. [*] PHP-FPM support from OS vendor
¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.