Apache no puede iniciarse debido al error "cgi_wrapper cannot be accessed"

Created:

2016-11-16 13:19:52 UTC

Modified:

2017-08-16 16:03:29 UTC

3

Was this article helpful?


Have more questions?

Enviar una solicitud

Apache no puede iniciarse debido al error "cgi_wrapper cannot be accessed"

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Síntomas

Apache no puede iniciarse tras haber actualizado PHP o MySQL:

 # /etc/init.d/httpd start
Starting httpd: Syntax error on line 90 of /var/www/vhosts/domain.tld/conf/13687485080.36736400_httpd.include:
Wrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper cannot be accessed: (2)No such file or directory
                                                           [FAILED]

O bien:

# service httpd start
Starting httpd: Syntax error on line 35 of /etc/httpd/conf/plesk.conf.d/horde.conf:
Wrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper cannot be accessed: (2)No such file or directory
[FAILED]

Los paquetes de PHP o MySQL se eliminaron y se volvieron a instalar.

Al ejecutar el comando que se muestra a continuación, se obtiene una salida vacía:

# rpm -q psa

O bien:

# rpm -q plesk-core

Causa

El paquete de Plesk se desinstaló como dependencia durante la eliminació de PHP o MySQL.

Por ejemplo, en algún momento durante la actualización se ejecutó el siguiente comando de forma manual para así eliminar los paquetes de PHP:

# yum remove php php-cli php-common php-devel php-gd php-mbstring

O bien:

# yum remove mysql-server

En la mayoría de sistemas, Plesk se desinstalará como resultado de la ejecución de este comando.

Resolución

Los paquetes de PHP y MySQL son dependientes de Plesk. De eliminarse, también se eliminará Plesk.

Le recomendamos encarecidamente que tenga mucha precaución cuando elimine paquetes en el servidor Plesk, especialmente por lo que respecta a la sección de dependencias.

En esta situación, Plesk debería volverse a instalar o bien debería restaurar el servidor mediante un backup.

Nota : no se soporta la actualización del sistema operativo en Plesk 12 y versiones anteriores. Si desea más información, haga clic [ aquí ].

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.