No es posible crear un cliente debido al error "Access denied for user 'apsc'@'localhost'"

Created:

2016-11-16 13:10:41 UTC

Modified:

2017-08-08 13:23:43 UTC

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No es posible crear un cliente debido al error "Access denied for user 'apsc'@'localhost'"

Síntomas

No es posible crear un cliente nuevo. La operación resulta fallida y se obtiene el siguiente error:

Internal error: 
ODBC error #HY000: [MySQL][ODBC 3.51 Driver]Access denied for user 'apsc'@'localhost' (using password: YES)

Cuando se intenta crear una suscripción o instalar una aplicación APS, se obtiene un error similar:

Internal error: ODBC error #HY000: [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ODBC error #HY000: [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ODBC error #HY000: 
File aps_php.php
Line 11933
Type Exception

Causa

La actualización de Plesk se completó con errores. La integración con la base de datos apsc no se completó correctamente.

Resolución

Plesk 11.5-12.5 para Linux:

Es posible reparar la integración con la base de datos apsc usando el script de restablecimiento masivo de contraseñas de Plesk tal y como se describe en este artículo . Deberá ejecutar el script con el siguiente parámetro:

Linux:

# /usr/local/psa/bin/sw-engine-pleskrun plesk_password_changer.php `cat /etc/psa/.psa.shadow` ['current admin password'] --apsc

Todas las versiones de Plesk para Windows y Plesk para Linux 11.0 y versiones anteriores :

1) Verifique que en Plesk existe información sobre la base de datos apsc :

**NOTA**: para realizar los pasos detallados a continuación para Windows, acceda primero a la base de datos `psa` y use las consultas de los ejemplos.

Linux:

    # mysql -uadmin -p`cat /etc/psa/.psa.shadow ` psa -e "select * from misc where param like 'aps%'"

Windows:

    "%plesk_dir%"\\mysql\\bin\\mysql.exe -uadmin -p<plesk_admin_password> -P8306 psa -e "select * from misc where param like 'aps%'"



    +----------------------+-----------+
| param | val |
+----------------------+-----------+
| aps_database | apsc |
| aps_host | 127.0.0.1 |
| aps_login | admin |
| aps_password | $AES-128-*** |
| aps_port | 8306 |
| aps_secure_passwords | false |
+----------------------+-----------+
6 rows in set (0.00 sec)

NOTA : si aps_password empieza por '$AES-128..' , esto significa que está cifrada. En este caso, proceda con el paso #2. Si la contraseña está en texto sin formato, proceda al paso #3.

Si no dispone de parámetros relacionados con apsc, puede añadirlos de forma manual:

INSERT INTO `misc` VALUES ('aps_database','apsc'),('aps_host','127.0.0.1'),('aps_login','apsc'),('aps_password','my_secret_password'),('aps_port','8306'),('aps_secure_passwords','false');


**NOTE:** Specify port **8306** for Windows and **3306** for Linux.

2) No es posible descifrar la contraseña del usuario apsc . De todos modos, puede obtener la contraseña original a través de los backups de la base de datos psa creados antes de actualizar Plesk a la nueva versión.

Por omisión, los backups se encuentran en el directorio /var/lib/psa/dumps en el caso de Linux y en "%plesk_dir%"\\mysql\\Backup en el caso de Windows. Abra el backup de psa y busque una línea como la siguiente:

('aps_password','<non_encrypted_passwd>'),('aps_port','8306')

Aquí, <non_encrypted_passwd> es la contraseña que necesita establecer.

3) Establezca los privilegios apropiados para la base de datos MySQL:

Linux:

    # mysql -uadmin -p`cat /etc/psa/.psa.shadow ` mysql -e "grant all privileges on apsc.* to 'apsc'@'localhost' identified by '<non_encrypted_password>'"

Windows:

    "%plesk_dir%"\\mysql\\bin\\mysql.exe -uadmin -p<plesk_admin_password> -P8306 mysql -e "grant all privileges on apsc.* to 'apsc'@'localhost' identified by '<non_encrypted_password>'"
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