No es posible actualizar Plesk debido al error "ERROR 1524 (HY000): Plugin 'Y' is not loaded"

Created:

2016-11-16 13:07:49 UTC

Modified:

2017-08-16 16:28:37 UTC

0

Was this article helpful?


Have more questions?

Enviar una solicitud

No es posible actualizar Plesk debido al error "ERROR 1524 (HY000): Plugin 'Y' is not loaded"

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Síntomas

La actualización de Plesk resulta fallida debido al siguiente error:

ERROR 1524 (HY000): Plugin 'Y' is not loaded

En el registro /var/log/mysqld.log puede ver la siguiente advertencia:

150824 20:12:02 [Warning] 'user' entry 'pma_YDHnd4Ja5pfe@localhost' has both a password and an authentication plugin specified. The password will be ignored.

Causa

Presencia de un valor incorrecto en la base de datos mysql .

Resolución

  1. Cree un backup de la base de datos mysql :

    mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` mysql > mysql.sql
  2. Compruebe el valor plugin para el usuario en cuestión:

    mysql> select plugin from mysql.user where User like '%pma_YDHnd4Ja5pfe%' \\G
    *************************** 1. row ***************************
    plugin: Y
    1 row in set (0.00 sec)
  3. Elimine el valor incorrecto mediante la siguiente consulta:

    mysql> update mysql.user set plugin = '' where User like '%pma_YDHnd4Ja5pfe%';
    Query OK, 1 row affected (0.01 sec)
    Rows matched: 1 Changed: 1 Warnings: 0
¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.