El dominio muestra la página de prueba predeterminada de Apache (y no la de Plesk) en vez de mostrar el contenido del dominio

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2016-11-16 13:04:21 UTC

2017-02-19 17:51:47 UTC

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El dominio muestra la página de prueba predeterminada de Apache (y no la de Plesk) en vez de mostrar el contenido del dominio

Síntomas

Algunos o todos los dominios muestran la página predeterminada de Apache y no la de Plesk.

Causa

Apache no alcanza las configuraciones añadidas por Plesk.

Resolución

  1. Compruebe que el nombre de dominio resuelve a la dirección IP en la que se ha configurado el hosting del dominio en Plesk. Apache y los hosts virtuales IIS se crean de forma estricta para que el nombre de host y la dirección IP coincidan y si la petición de un dominio llega a una dirección IP que no es la especificada en la configuración del host virtual, esta será gestionada por el host virtual predeterminado, motivo por el que se mostrará la página predeterminada del servidor web.

    Para conocer la dirección IP utilizada por el host virtual, examine la configuración de hosting del dominio ( Dominios > dominio > Configuración de hosting web en Plesk 9.x y versiones anteriores o Suscripciones > domain.tld > pestaña Sitios web y dominios > Acceso a hosting web en Plesk 10 y versiones posteriores). A continuación, compare esta dirección IP con la dirección IP a la que resuelve el dominio. Asimismo, intente verificar el registro DNS en distintos servidores DNS, incluyendo su propio servidor. Si desea más información acerca de cómo solucionar problemas de resolución, consulte este artículo de nuestra base de conocimiento.

    C:\\>nslookup domain.test
    Name: domain.test
    Address: 1.2.3.4

    De detectarse alguna no coincidencia, modifique los registros DNS o vuelva a asignar el dominio a la dirección IP apropiada.

  2. Intente abrir un documento no predeterminado para el dominio (http://domain.tld). Abra una página determinada, como por ejemplo http://www.domain.tld/mytest.html. Tenga en cuenta que el archivo mytest.html debe estar presente en la carpeta httpdocs del dominio. Si funciona, lo más probable es que el dominio no disponga de una página de índice o bien que esta página no esté presente en la directiva DirectoryIndex del archivo de configuración principal de Apache ( httpd.conf ).

    Generalmente, los archivos de índice tienen nombres como "index.html" o "index.php", si bien puede cambiar el nombre a su conveniencia. Puede modificar DirectoryIndex en httpd.conf en función de sus necesidades particulares. Por ejemplo:

    DirectoryIndex index.html index.htm index.shtml index.php index.php3 my_index.html

A continuación, reinicie Apache para que se apliquen los cambios efectuados.

  1. Intente volver a crear los archivos de configuración de Apache para el dominio:

    Plesk 10 y versiones posteriores :

    # /usr/local/psa/admin/bin/httpdmng --reconfigure-domain <domain_name>

    Plesk 9 y versiones anteriores :

    # /usr/local/psa/admin/bin/websrvmng --reconfigure-vhost --vhost-name=<domain_name>

    Nota : reemplace <domain_name> por el nombre de dominio actual.

    Si experimenta esta incidencia en todos los dominios, puede ejecutar el siguiente comando:

    Plesk 10 y versiones posteriores :

    # /usr/local/psa/admin/bin/httpdmng --reconfigure-all

    Plesk 9 y versiones anteriores :

    # /usr/local/psa/admin/bin/websrvmng --reconfigure-all
  2. Si dispone de un servidor de pruebas, intente comparar su archivo de configuración principal de Apache con el del servidor donde experimenta el problema. Compruebe que las siguientes líneas están presentes:

    NameVirtualHost <IP>:80
    NameVirtualHost <IP>:443
    Include conf.d/*.conf

    Nota : reemplace <IP> por la dirección IP actual de su servidor.

  3. Si tiene instalado nginx pero no lo utiliza, intente activar y desactivar el soporte para nginx :

       # /usr/local/psa/admin/sbin/nginxmng -e
    # /usr/local/psa/admin/sbin/nginxmng -d
  4. Si usa nginx , compruebe su estado:

    # /etc/init.d/nginx status 
    nginx dead but pid file exists

    Para solucionar la incidencia, realice los siguientes pasos:

    6.1. Cree un backup de nginx.pid:

        # mv /var/run/nginx.pid /var/run/nginx.pid_bak

    6.2. Active el servicio de nginx:

        # /usr/local/psa/admin/bin/nginxmng -e

    6.3. Desactive el servicio de nginx:

        # /usr/local/psa/admin/bin/nginxmng -d

    6.4. Vuelva a activar el servicio de nginx:

        # /usr/local/psa/admin/bin/nginxmng -e

    6.5. Vuelva a crear los archivos de configuración web:

        # /usr/local/psa/admin/bin/httpdmng  --reconfigure-domain <domain_name>
  5. Compruebe que zz010_psa_httpd.conf está presente en /etc/apache2/conf-enabled/ .

       # ln -s /etc/apache2/conf.d/zz010_psa_httpd.conf /etc/apache2/conf-enabled/
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