Soporte completo de PHP 7 en Plesk 12.5

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 13:00:30 UTC

Modified:

2017-02-22 13:25:35 UTC

6

Was this article helpful?


Have more questions?

Enviar una solicitud

Soporte completo de PHP 7 en Plesk 12.5

Nos complace anunciar el soporte completo de PHP 7 en Plesk 12.5 tanto para Windows como para Linux. PHP 7 ofrece infinidad de prestaciones nuevas y optimizaciones , entre las que se incluye una mejora notable del rendimiento. A continuación puede ver las instrucciones para su instalación y las incidencias conocidas.

Instalación

  • Instalación mediante el GUI

    Simplemente vaya al interfaz de Plesk Installer y seleccione el componente PHP 7 ( Añadir/Eliminar componentes > Prestaciones de hosting web > Distintas versiones de interpretadores PHP ).

alttext

  • Instalación mediante el CLI

En Linux:

    #plesk sbin autoinstaller --select-product-id plesk --select-release-current  --install-component php7.0

En Windows:

    "%plesk_bin%"\\ai.exe -select-product-id plesk --select-release-current  --install-component php70

Una vez finalizada la instalación, podrá seleccionar PHP 7 en la configuración de hosting de sitios web y planes de servicio.

Nota: examine las instrucciones para el uso de múltiples versiones de PHP aquí .

Limitaciones y problemas conocidos

  • En este momento solo existen dos aplicaciones del catálogo APS que soporten PHP 7 en los sitios web de los clientes: WordPress y Drupal.
  • El módulo OPCache está desactivado por defecto en Windows debido a la incidencia https://bugs.php.net/bug.php?id=71024 de PHP. Esta incidencia únicamente afecta a aquellos sitios que ejecuten distintas versiones de PHP en el mismo inventario de aplicaciones IIS. Si su sitio no se ve afectado por esta incidencia, puede activar el módulo OPCache haciendo clic en Configuración PHP y estableciendo activado en la opción opchache.enable ).
  • PHP 7 aún no aparece en la lista de componentes presentes en Herramientas y configuración > Componentes del servidor en Linux. Esto se corregirá en una de las próximas actualizaciones de Plesk.
  • PHP 7 sólo está disponible para Plesk 12.5.
¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.