¿Es seguro actualizar paquetes de sistema usando el administrador de paquetes del sistema operativo?

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

2016-11-16 12:48:50 UTC

2017-02-10 22:03:02 UTC

1


Enviar una solicitud

¿Es seguro actualizar paquetes de sistema usando el administrador de paquetes del sistema operativo?

Resolución

Sí, lo que es más: recomendamos el uso de administradores de paquetes (como '"yum" en sistemas basados en RedHat o "apt-get" en sistemas basados en Debian) para mantener el sistema debidamente actualizado.

De todos modos, es posible que algunos paquetes entren en conflicto con Plesk u otro software. Estos paquetes pueden añadirse a la lista de ignorados. La configuración recomendada es la siguiente:

  • en el caso de up2date , añadir a /etc/sysconfig/rhn/up2date :

     pkgSkipList=kernel*;sendmail;bind-chroot;caching-nameserver;
  • en el caso de yum , añadir a /etc/yum.conf :

     exclude=kernel* sendmail bind-chroot caching-nameserver
  • en el caso de apt-get , ejecutar con:

    sudo apt-mark hold <package>

    O bien puede usar dpkg :

    echo <package> hold | sudo dpkg --set-selections

Si desea descubrir qué debe realizar tras actualizar Apache en un sistema Plesk, consulte el siguiente artículo de nuestra base de conocimiento:

#213411089 ¿Es posible actualizar Apache a la versión más reciente a través de la actualización de un SO?

Si Plesk se ha instalado en un contenedor, no es necesario actualizar el kernel, ya que este debería actualizarse a través del nodo hardware. Si Plesk se ha instalado en un servidor de hardware, las actualizaciones del kernel se recomiendan si únicamente se han configurado repositorios del proveedor. De lo contrario, si los repositorios personalizados proporcionan nuevos kernels, es preferible actualizar el kernel manualmente a través del repositorio del proveedor. Esto se debe a que la mayoría de problemas vienen ocasionados por kernels a los que se ha aplicado parches GRSecurity. Plesk no está diseñado para operar con este tipo de configuraciones.

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.