Nginx no se inicia tras haber realizado un cambio de IP

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:41:53 UTC

Modified:

2017-02-17 10:20:19 UTC

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Nginx no se inicia tras haber realizado un cambio de IP

Síntomas

  • En la página principal de Plesk se observa el siguiente error:

    New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [emerg] bind() to 10.9.23.65:80 failed (99: Cannot assign requested address) nginx: configuration file /etc/nginx/nginx.conf test failed . The error message containing the detailed error descriptions was sent to you by e-mail. Please resolve the issues and click here to generate broken configuration files once again or here to generate all configuration files.
  • Nginx no puede iniciarse:

    [emerg] bind() to 10.9.23.65:80 failed (99: Cannot assign requested address) ;

Causa

  • La dirección IP se eliminó directamente del servidor pero no de Plesk.

  • La dirección IP del servidor se cambió directamente en el servidor. Plesk no actualizó la configuración de forma automática.

Resolución

  1. Sincronice la base de datos de Plesk y las direcciones IP en el servidor:

    # /usr/local/psa/bin/reconfigurator --autoconfigure

    Please pay attention to the output of the first command. It may contain the same IP address listed in several sections and also some IP addresses listed under '`Database`' but not listed under `'Actual'`:

    [root@srv ~]# /usr/local/psa/bin/reconfigurator --autoconfigure
    Database: [<1.2.3.4>, <5.6.7.8>, <9.1.2.2>, <8.1.2.3>, <7.1.2.3>, <6.1.2.3>, <0000:a0a0:0000:a0:225:00a0:0a00:0a00]
    Actual: <1.2.3.4>, <5.6.7.8>, <9.1.2.2>, <8.1.2.3>, <7.1.2.3>, <6.1.2.3>]
    Removed IPs: [] [<0000:a0a0:0000:a0:225:00a0:0a00:0a00>]
    Added IPs: [] []
    Mapping: {}
    Old not remapped: [<0000:a0a0:0000:a0:225:00a0:0a00:0a00>]
    New not used: []

    Este caso indica que la dirección Ipv6 0000:a0a0:0000:a0:225:00a0:0a00:0a00 se eliminó directamente a través del interfaz del servidor.

  2. Para reparar la dirección IP, efectúe lo siguiente:

    a. Vaya a Herramientas y configuración > Direcciones IP

    b. Si alguna dirección IP se destaca con un signo de exclamación y se muestra como dañada, haga clic en el enlace reparar o elimine la dirección de Plesk si ya no la utiliza y no existe en el servidor.

    c. Si existe ninguna dirección dañada, haga clic en volver a leer para que así las direcciones dañadas sean reparadas.

  3. Ahora vuelva a configurar el servidor web:

    # /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
  4. Inicie nginx:

    # /etc/init.d/nginx restart
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