¿Es posible actualizar Apache a la versión más reciente a través de la actualización de un SO?

Created:

2016-11-16 13:20:52 UTC

Modified:

2017-08-16 18:25:58 UTC

0

Was this article helpful?


Have more questions?

Enviar una solicitud

¿Es posible actualizar Apache a la versión más reciente a través de la actualización de un SO?

Applicable to:

  • Plesk 12.0 for Linux

Resolución

El propio interfaz del panel de control solo es servido por un servicio especial independiente en los puertos 8443 y 8880. Las versiones 7.x y 8.x de Parallels Plesk utilizan el servicio httpsd (basado en una compilación personalizada de Apache). Las versiones 9.x usan el servicio sw-cp-server (basado en una compilación personaliza de lighttpd )para servir el panel de control. Estos servicios no pueden ser modificados.

De todos modos, los sitios web en Parallels Plesk (PP) son alojados y servidos por el sistema Apache estándar, que forma parte de la distribución del sistema operativo. Esta puede actualizarse libremente con las actualizaciones pertinentes de Apache para este SO a través del proveedor del sistema operativo.

En Parallels Plesk 7.x es necesario reemplazar el archivo /usr/sbin/suexec de forma manual tras haber actualizado el paquete de Apache. Para realizar el reemplazo puede ejecutar los siguientes comandos:

~# cp /usr/local/psa /suexec/psa-suexec /usr/sbin/suexec
~# chown root:apache /usr/sbin/suexec
~# chmod 4510 /usr/sbin/suexec

Aquí, /usr/local/psa es $PRODUCT_ROOT_D .

NOTAS:

1) En versiones de Parallels Plesk anteriores a la versión 7.5.4 , psa-suexec se encuentra en /usr/sbin/psa-suexec .

2) En Parallels Plesk 11.5 , psa-suexec se encuentra en /usr/lib64/plesk-9.0/suexec/psa-suexec

En Parallels Plesk 8.x y 9.x , Parallels Plesk incorpora un trigger que reemplaza suexec tras la actualización del paquete de Apache. En CentOS, el trigger tiene la siguiente apariencia:

---8<---
cp -f /usr/local/psa /suexec/psa-suexec /usr/sbin/suexec
chown root:apache /usr/sbin/suexec
chmod 4510 /usr/sbin/suexec
--->8---


Como consecuencia, en Parallels Plesk 8.x y 9.x , no es necesario reemplazar /usr/sbin/suexec tras la actualización del paquete de Apache.
¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.