No aparece la pestaña Correo en el software de Plesk de un dominio

Created:

2016-11-16 13:19:11 UTC

Modified:

2017-08-16 14:13:26 UTC

1

Was this article helpful?


Have more questions?

Enviar una solicitud

No aparece la pestaña Correo en el software de Plesk de un dominio

Applicable to:

  • Plesk for Linux/Unix
  • Plesk for Windows

Síntomas

No aparece la pestaña Correo en el software de Plesk de un dominio.

Causa

La suscripción se creó antes de instalar el servidor de correo. Como resultado, la entrada de servicio no está presente en la base de datos.

Resolución

  1. Activar el servicio de correo para ese dominio:

    Linux:

    # /usr/local/psa/bin/domain --update example.com -mail_service true
    # /usr/local/psa/bin/domain --info example.com | grep 'Mail service'
    Mail service:                           On
    

    Windows:

    "%plesk_dir%\bin\domain" --update example.com -mail_service true
    "%plesk_dir%\bin\domain" --info example.com | findstr /C:"Mail service"
    Mail service:                           On
    
  2. Si no ha podido resolver la incidencia con las indicaciones anteriores, lleve a cabo los siguientes pasos:

    Recuperación automática (solo Linux)

    • Descargue este script para Linux

      # wget http://kb.odin.com/Attachments/kcs-506/mail_restore.sh
      
    • Conviértalo en ejecutable:

      # chmod +x ./mail_restore.sh
      
    • Ejecute el script con un nombre de dominio como argumento:

      # ./mail_restore.sh example.com
      

    Recuperación manual (Linux y Windows)

    1. Acceda a la base de datos psa tal como se indica en este artículo .

    2. Ejecute las siguientes consultas, sustituyendo el nombre de dominio por el nombre pertinente:

      mysql> SELECT @ID:=max(id)+1 FROM psa.Parameters;
      +----------------+
      | @ID:=max(id)+1 |
      +----------------+
      |              6 |
      +----------------+
      
      mysql> INSERT INTO psa.Parameters VALUES (@ID,'mailProviderInstanceId','');
      
      mysql> INSERT INTO psa.Parameters VALUES (@ID,'mailProviderType','local');
      
      mysql> INSERT INTO psa.Parameters VALUES (@ID,'mailProviderUid','local');
      
      mysql> INSERT INTO psa.Parameters VALUES (@ID,'nonexist_mail','reject');
      
      mysql> SELECT @IPID:=max(id)+1 FROM psa.IpCollections;
      +------------------+
      | @IPID:=max(id)+1 |
      +------------------+
      |             11   |
      +------------------+
      
      mysql> INSERT INTO psa.IpCollections VALUES (@IPID);
      
      mysql> SELECT @DOMID:=d.id,@IP:=ip.ipAddressId 
             FROM psa.domains d JOIN psa.DomainServices ds ON d.id=ds.dom_id 
             JOIN psa.IpAddressesCollections ip ON ds.ipCollectionId=ip.ipCollectionId 
             WHERE d.name='DOMAIN.TLD'; <==================== Only one parameter is needed, domain name.
      +--------------+---------------------+
      | @DOMID:=d.id | @IP:=ip.ipAddressId |
      +--------------+---------------------+
      |            1 |                   1 |
      +--------------+---------------------+
      
      mysql> INSERT INTO psa.IpAddressesCollections VALUES (@IPID, @IP);
      
      mysql> INSERT INTO psa.DomainServices (dom_id,type,status,parameters_id,ipCollectionId) values (@DOMID,'mail',0,@ID,@IPID); 
      

El siguiente artículo de nuestra base de conocimiento también puede serle de utilidad:

121481 - Después de realizar la instalación de la licencia de Plesk, no aparecen algunos botones en el panel o la interfaz de Plesk ha cambiado

Attachments:

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.