La llave de licencia sólo puede usarse en el caso de que Plesk opere en los siguientes entornos virtuales

Created:

2016-11-16 13:12:09 UTC

Modified:

2017-06-05 06:07:00 UTC

2

Was this article helpful?


Have more questions?

Enviar una solicitud

La llave de licencia sólo puede usarse en el caso de que Plesk opere en los siguientes entornos virtuales

Consulta

Cuando se intenta abrir el interfaz de Plesk o actualizar una llave de licencia se obtiene el siguiente error:

Error: The license key is invalid. In order to use Plesk, you need to obtain and install a new valid license key.
The license key is intended only for use with Plesk operating inside the following virtual environments: Virtuozzo containers, VMWare, Microsoft Hyper-V, Xen, KVM, Virtuozzo Server, LXC, Docker.

Causa

Este problema puede deberse a distintas causas:

  • Plesk no se ha instalado en un entorno de virtualización soportado
  • BIOS hackeada en la máquina física
  • Una máquina virtual configurada de forma incorrecta se detecta como si fuera un host físico
  • Límites aumentados en un contenedor

Resolución

Plesk únicamente soporta las siguientes soluciones de virtualización:

VMware
XEN
Virtuozzo (former Parallels Cloud Server 6)
OpenVZ
Virtuozzo containers 4.6 for Linux
Virtuozzo containers 4.6 for Windows
Virtuozzo containers 4.7 for Linux
LXC (Docker)
KVM
Hyper-V

De no soportarse el entorno de virtualización, cargue una licencia dedicada de Plesk, no una licencia VPS.

Para ver cómo Plesk detecta el entorno en el que se ejecuta, use uno de los siguientes métodos:

  • En el caso de Plesk 12.0 y versiones posteriores, use el siguiente script tanto para Linux como para Windows. Cree un archivo con el siguiente código (denominado info.php ):
    <?php
    require_once('api-common/cu.php');

    cu::initCLI();
    $cu = new cu();
    try {
    $si = var_export(getServerInfo(), true);
    cu::print_stdout($si);

    } catch(Exception $e) {
    cu::print_stderr("Error: " . $e->getMessage());
    cu::cuExit(1);
    }

    cu::cuExit(0);

A continuación, ejecútelo en Windows:

    "%plesk_bin%\\php.exe" info.php | findstr platform

O en Linux:

    /usr/local/psa/bin/sw-engine-pleskrun info.php | grep platform

En una pantalla podrá ver el resultado de la detección de Plesk. dedicated o none son el hardware físico.

  • En el caso de Plesk 11.5 o versiones anteriores, ejecute el siguiente comando:

Para Windows:

    "%plesk_bin%\\php.exe" -dauto_prepend_file= -r "echo get_virtualization();"

Para Linux:

    /usr/local/psa/bin/sw-engine-pleskrun -dauto_prepend_file= -r "echo get_virtualization();"
  • En el caso de Linux, puede usar otras utilidades no relacionadas con Plesk, como por ejemplo dmidecode y lspci .

  • Asimismo, en el caso de Windows, puede realizar los pasos detallados a continuación para obtener la información de la BIOS:

  • Ejecute wbemtest en la línea de comandos.

  • Haga clic dos veces en Connect .

  • Haga clic en Query .

  • Ejecute lo siguiente:

    SELECT * FROM Win32_BIOS

Si como resultado de esta acción obtiene la información de la BIOS similar a Version='ACRSYS - 1' , esto significa que la BIOS ha sido hackeada y que debería desactivar el hack o bien que debe obtenerse una licencia para servidores dedicados.

Si la salida sugiere que se está experimentando la inexistencia de una plataforma virtual, no hay forma alguna de que Plesk la detecte a menos que vuelva a desplegarse correctamente con la configuración apropiada.

  • Asimismo, compruebe que el servicio Plesk Management está operativo y en ejecución. Reinicie los servicios de gestión de Plesk:

En Windows:

Acceda al servidor como > 'Administrador' > Todos los programas > 'plesk services monitor' > Reiniciar 'Plesk Management Services'

En Linux:

    $ /etc/init.d/psa stop
$ /etc/init.d/psa start

Confírmelo ejecutando el siguiente comando en el servidor:

+++
"%plesk_bin%\\php.exe" -dauto_prepend_file= -r "echo get_virtualization();"
zen
++++

Si estos pasos no le ayudan a resolver la incidencia, compruebe el archivo /usr/local/psa/admin/logs/panel.log para examinar el error exacto que se obtiene cuando se intenta instalar o recuperar una licencia. Si no existe ningún error de tipo "Fork failed - Cannot allocate memory" en panel.log , consulte el siguiente artículo de nuestra base de conocimiento:

213959545 Error: Fork failed - Cannot allocate memory

Información adicional

Plesk 12.0 para Windows:

213363669 Plesk muestra el error "The license key is invalid." Para utilizar Plesk es necesario obtener e instalar una nueva llave de licencia válida.

Si la virtualización del servidor se detecta como xen pero la licencia no puede cargarse debido a la obtención del mismo error, visite:

# virt-what
xen

214527425 No se puede instalar la licencia de Plesk. La llave de licencia sólo puede utilizarse con Plesk operando en los siguientes entornos virtuales

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.