El administrador de backups de Plesk tarda mucho en cargarse y cuando lo hace muestra el error "Nginx 504 Gateway Time Out"

Created:

2016-11-16 13:08:34 UTC

Modified:

2017-07-07 07:55:32 UTC

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El administrador de backups de Plesk tarda mucho en cargarse y cuando lo hace muestra el error "Nginx 504 Gateway Time Out"

Síntomas

  1. Cuando intento abrir el administrador de backups de Plesk haciendo clic en Herramientas y configuración -> Administrador de backups , este tarda mucho en cargarse y cuando lo hace muestra el error Nginx 504 Time Out Gateway .

  2. El servicio nginx está desactivado.

  3. El registro de errores sw-cp-server contiene el siguiente error:

less /var/log/sw-cp-server/error_log

2014/01/07 16:49:33 [error] 3235#0: *1483 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 123.123.123.12, server: , request: "GET /plesk/server/backup/local-repository/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock", host: "11.12.13.14:8443", referrer: "https://11.12.13.14:8443/admin/server/tools?context=tools"

4. Cuando se accede al administrador de backups, puede verse el proceso pmmcli :

# ps ax | grep pmm
11357 ? R 0:37 /usr/bin/python /usr/local/psa/admin/sbin/pmmcli --get-tasks-list Restore,Backup 5dfb2ce3-1743-4cac-902e-78773bc245d6 any

Parece que el proceso está bloqueado.

Causa

Compruebe si existen archivos migration.result con un gran número de líneas. El administrador de backups intenta obtener el estado de los backups y tarda demasiado en analizar las líneas y cargar todos los errores de archivos como /usr/local/psa/PMM/sessions/2013-08-25-030202.954/migration.result . Este comportamiento se considera una incidencia de software, a la que se ha asignado la referencia #PPPM-2035.

Generalmente, este contiene los mensajes "Permission denied":

egrep -lir 'Permission denied' /usr/local/psa/PMM/sessions/ | xargs wc -l
34544 /usr/local/psa/PMM/sessions/2013-11-13-030003.384/migration.result
34544 /usr/local/psa/PMM/sessions/2013-12-22-013005.54/migration.result
34543 /usr/local/psa/PMM/sessions/2013-12-05-013004.227/migration.result
34534 /usr/local/psa/PMM/sessions/2013-11-06-030003.347/migration.result
35502 /usr/local/psa/PMM/sessions/2013-11-10-030003.623/migration.result

Resolución

  1. Busque los archivos que no presentan permisos correctos. El administrador de backups no pudo obtener acceso al contenido mencionado en los archivos migration.result para añadirlo al archivo comprimido. Para consultar las instrucciones a seguir, consulte este artículo .

  2. Cree un backup del directorio de sesiones actual antes de aplicar ningún cambio:

    mkdir /usr/local/psa/PMM/sessions_backup/
    cp -a /usr/local/psa/PMM/sessions/* /usr/local/psa/PMM/sessions_backup/
  3. Elimine las líneas que presentan el mensaje 'Permission denied' de los archivos /usr/local/psa/PMM/sessions/*/migration.result:

     grep -lir 'Permission denied' /usr/local/psa/PMM/sessions_copy/ | xargs sed -i '{;/denied/d;}'
  4. Elimine los procesos pmmcli actuales si estos no están relacionados con los procesos de migración y backup actuales:

    # ps ax | grep pmmcli | grep -v grep

    12146 ? R 49:39 /usr/bin/python /usr/local/psa/admin/sbin/pmmcli --get-tasks-list Restore,Backup 73406802-7e5a-44e4-9b14-aa2cbf201973 any
    13275 ? R 36:15 /usr/bin/python /usr/local/psa/admin/sbin/pmmcli --get-tasks-list Restore,Backup 73406802-7e5a-44e4-9b14-aa2cbf201973 any

    # kill -9 12146 13275
  5. Compruebe el acceso al administrador de backups.

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