Configuración de controladores PHP

Created:

2016-11-16 12:57:00 UTC

Modified:

2017-07-18 17:25:56 UTC

3

Was this article helpful?


Have more questions?

Enviar una solicitud

Configuración de controladores PHP

Consulta

¿Cómo puedo configurar PHP para usarlo para el procesamiento de scripts PHP? ¿Soporta Plesk mod_php?

Resolución

Por defecto, Plesk usa el módulo PHP para el procesamiento de escenarios PHP (conocidos como mod_php).

Puede configurar el uso de los siguientes controladores PHP:

  • ISAPI (Windows)
  • Módulo Apache (Linux)
  • FastCGI
  • CGI
  • PHP-FPM (Linux)

La elección del controlador variará en función de las consideraciones de seguridad, de la velocidad de ejecución de los scripts y del consumo de memoria. Si desea más información sobre las prestaciones de los controladores PHP, consulte la guía del administrador de Plesk .

Puede seleccionar un controlador PHP para un plan de servicio o un sitio web, respectivamente, en:

  • configuración del plan de servicio (pestaña Parámetros de hosting > Scripting > Ejecutar PHP como )

  • configuración del sitio web ( Panel de control > Sitios web y dominios > seleccione un dominio > Configuración de hosting > Ejecutar PHP como )

Nota: tal y como se indica en la guía del administrador de Plesk , PHP-FPM no puede seleccionarse para todos los sitios web a la vez en la configuración de plan de hosting. Este controlador sólo puede usarse para sitios web individuales.

Nota: si cambia PHP del módulo Apache a la aplicación FastCGI, es posible que la funcionalidad de los scripts PHP existentes se vea afectada. Asimismo, el hecho de cambiar PHP-FPM seleccionando Procesar PHP mediante nginx en la configuración del servidor web del sitio web puede tener el mismo resultado.

Plesk soporta distintas versiones de PHP. Puede seleccionar una o más versiones de PHP para cada uno de los controladores disponibles. Si desea más información al respecto, consulte la sección Múltiples versiones de PHP de la guía del administrador.

La lista de controladores de PHP disponibles en la interfaz de usuario de Plesk varía en función del sistema operativo y del servidor web que procesa los archivos de PHP. Uno de los controladores, PHP-FPM, también necesita instalarse con Parallels Installer.

Asimismo, puede desactivar los módulos de servidor web Apache que no sean críticos para los servicios de hosting en Herramientas y configuración > Servidor web Apache . Esto le permitirá reducir el consumo de recursos del servidor (por ejemplo, reducir el consumo de RAM - un elemento crítico para un VPS) y, como resultado, dar servicio a más clientes de hosting en un servidor.

Tenga en cuenta que algunos módulos tienen dependencias entre ellos y que solo pueden desactivarse / activarse cuando los módulos de los que dependen están desactivados / activados.Por ejemplo, el módulo de caché depende de los módulos disk_cache , file_cache y mem_cache . Esto significa que usted no puede desactivar la caché hasta que se hayan desactivado estos tres módulos dependientes.

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.