La actualización de PHP en CentOS 6 ocasiona problemas en scripts que se ejecutan como CGI o FastCGI.

Created:

2016-11-16 12:53:40 UTC

Modified:

2017-06-05 06:15:38 UTC

0

Was this article helpful?


Have more questions?

Enviar una solicitud

La actualización de PHP en CentOS 6 ocasiona problemas en scripts que se ejecutan como CGI o FastCGI.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 10.4 for Linux/Unix

Síntomas

Una vez la tarea semanal de actualizaciones de Plesk ha completado la instalación de la actualización de PHP, los scripts PHP no pueden gestionar objetos de sesión en sitios que se han configurado para ejecutar PHP como CGI o FastCGI.

Causa

El proveedor del sistema operativo publicó una actualización para PHP en CentOS 6 y esta fue instalada por el proceso semanal de actualizaciones de Plesk. Dicha actualización de PHP restableció los parámetros de propiedad y los permisos sobre el directorio /var/lib/php/session a sus valores predeterminados, lo que impide a los usuarios FTP de dominios crear archivos en el directorio. Como los scripts CGI y FastCGI PHP se ejecutan basándose en los privilegios de los usuarios FTP, los scripts que intentan crear objetos de sesión experimentan problemas.

Resolución

La microactualización 42 de Plesk 11.0.9 repara los permisos sobre el directorio de sesión de PHP (consulte las notas de la versión ). Asimismo, a partir de ahora, cada vez que complete una actualización se verificarán y repararán los permisos del directorio de sesión de PHP.

Solución provisional

Ejecute los siguientes comandos para establecer los permisos correctos y la configuración de propiedad apropiada sobre /var/lib/php/session :

chmod 1733 /var/lib/php/session
chown root:root /var/lib/php/session

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.